Upstream Proxy ServerName not set?


#1

Hey there;

Been having an issues with running two APIs on tyk.

They have custom domains:

gateway.api1.com
gateway.api2.com

the setup is that:

  1. nginx picks up the incoming
  2. routes it to tyk via an upstream server
  3. tyk pushes this to apache which is listening on http://127.0.0.1.8080

so the issue is that Apache only reads the FIRST virtual server defined when requests come through this route. It seems as though Tyk may not be sending through something that Apache can use to determine the ServerName directive with.

stuff tried
I have bypassed tsk and then accessed apache directly with just the nginx proxy and it works just fine.

i have setup apache to listen on 8080 and 8181 and then used different ports for the same requests with the same results.

Is there some setting I am forgetting to get Tyk to send through the right data?

Thanks

JW


#2

Never mind. I had conflicting blocks in Apache.

beats self repeatedly dunce cap


#3