Tyk Hybrid REST API to create apis errors

I am trying to POST/PUT api definitions to api/apis and api/apis/[internalid] respectively, but get a 400 Bad Request without any other details.

I am sending in

POST /api/apis HTTP/1.1
Host: admin.cloud.tyk.io
Accept-Encoding: identity
Content-Length: 4797
Authorization: [my api key]

[json from https://tyk.io/docs/tyk-rest-api/api-management/ changing the org_id]

I am able to get the list of APIs via GET /api/apis HTTP/1.1 and my api key, so I know my api key is working.

I have tried various jsons to post including the sample on your site as well as exported (both full and empty) api defintions already running – changing the paths. All of those jsons will work via dashboard web’s Import function.

The same error happens with PUT /api/apis/[internalid] HTTP/1.1

What could I be doing wrong?

You must use the Tyk dashboard APIs with cloud, the gateway API is unavailable - you can do all the same things with the dashboard API.

1 Like

Thanks that worked.

(though an error details w/ the 400 Bad Request would probably have gotten me there quicker – i.e. api_definition element not found or something. )