Tyk-gateway service gone after updating to 2.2


#1

Hi,

I am using tyk on a centos 6.5 machine. Tyk gateway 2.1 was running smoothly along with tyk dashboard and tyk-pump. I tried to update to version 2.2. I have made a backup of my tyk.conf file and then i run the command:
-> yum update tyk-gateway
The update process went smoothly, confirmed the installation of 2.2 and then tried to start the service after I updated the new tyk.conf file with my current configuration settings from the old tyk.conf file.
My problem is that whenever I try to start the tyk-gateway service (-> service tyk-gateway start ) from the /etc/init.d/ folder i get a message:
tyk-gateway: unrecognized service
I rebooted the system but the problem remains. There is no service to start. I have also tried to run the install script for the tyk-gateway folder (->/opt/tyk-gateway/install/setup.sh) with my current options but this only made a new tyk.conf file which i updated with my current configuration options. Again nothing changed and there is no service to start.

I am not an experienced linux user so please excuse my simplified description of the problem.

Thanks in advance,
Nikos


#2

Hi Nikos, that’s quite odd - you might just want to do an install instead of an update (yum install tyk-gateway), this will trigger all the hooks to install the service scripts.


#3

Martin, ‘yum install’ wasn’t letting me do anything because it said that tyk-gateway was already installed, but then i tried to do
-> yum reinstall tyk-gateway
and after the installation finished the service started !! Thanks a lot!