Enforced Timeout Plugin in TYK


I am working on using Enforced Timeout Plugin for my New API.

I have set a enforced timeout of 300s in TYK Dashboard.

But when posting a request i am getting There was a problem proxying the request. after Just 1 min.

TYK Gateway: 2.9.2

I am not sure is this a bug. How can we increase this timeout.

Hi @Tushar456,

Thanks for writing in!

Im currently investigating this a bit further. I’ll get back to you as soon as I have an update!


Hi @Tushar456,

Are you using Tyks Virtual Endpoints: Virtual Endpoints ?

If so that’s why you’re seeing unexpected results. Enforced Timeout plugin only works with real http requests. Essentially it’s a HTTP protocol level timeout which means it won’t be applied to the virtual endpoint.

JSVM/VP timeouts should be controlled via the jsvm_timeout option in the tyk.conf file.

I hope this helps,


1 Like

Hi @Valmir,

Is it "jsvm_timeout": 30 that goes into the root level of tyk.conf? There also seems to be another
jsvm_http_request_timeout: 120 and I can at least tell that does not work at the root level.

Tyk CE 3.2.4

UPDATE: Turns or jsvm_timeout in the root of tyk.conf works.