Virtual Endpoint Not Working


#1

Imported Google Group message. Original thread at: https://groups.google.com/forum/#!topic/tyk-community-support/qmT9R-pSzLk Import Date: 2016-01-19 21:43:04 +0000.
Sender:Kangaroozal.
Date:Tuesday, 12 January 2016 21:00:44 UTC.

Hi there,

I’m attempting to create my first virtual endpoint using Tyk. I’m currently using the dashboard UI / endpoint designer. I’m running the whole stack (gateway, dashboard, mongo, redis) using the supplied docker-compose config (version 1.9).

I’m unable to get even the most basic virtual endpoint operational. By using the endpoint designer I’ve entered “sampleVirtual” for the “JS function to call” and entered the function definition for “sampleVirtual” below it in the “Code Editor:” field. I’m not sure what I’m missing for this JS code to trigger when that endpoint is requested. Every-time I request that endpoint I simply get a “404” and nothing is displayed in the logs.

If there is a super simple sample that I could use for those two fields to ensure I’m not doing something silly, that would be amazing!

Any help you could provide would be awesome!

Cheers!


#2

Imported Google Group message.
Sender:Martin Buhr.
Date:Tuesday, 12 January 2016 21:14:17 UTC.

Hi,

Have you enabled the JSVM? The JavaScript VM is disabled by default as it improves overall performance:

https://tyk.io/v1.9/configuration/configuration/#enable-jsvm:a66b35d20295cb764719ac8bd35837ec

That mgt be why :slight_smile:

Cheers,
Martin

  • show quoted text -

  • show quoted text -


You received this message because you are subscribed to the Google Groups “Tyk Community Support” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To view this discussion on the web, visit https://groups.google.com/d/msgid/tyk-community-support/b42af260-4b10-4a59-be36-df5eb5a15c2b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


#3

Imported Google Group message.
Sender:Kangaroozal.
Date:Tuesday, 12 January 2016 21:14:17 UTC.

Hi,

Have you enabled the JSVM? The JavaScript VM is disabled by default as it improves overall performance:

https://tyk.io/v1.9/configuration/configuration/#enable-jsvm:a66b35d20295cb764719ac8bd35837ec

That mgt be why :slight_smile:

Cheers,
Martin

  • show quoted text -

  • show quoted text -


You received this message because you are subscribed to the Google Groups “Tyk Community Support” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To view this discussion on the web, visit https://groups.google.com/d/msgid/tyk-community-support/b42af260-4b10-4a59-be36-df5eb5a15c2b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


#4

Imported Google Group message.
Sender:Martin Buhr.
Date:Wednesday, 13 January 2016 00:15:33 UTC.

Awesome!!!

Worked like a jiffy!

Cheers mate!

  • show quoted text -