Vagrant install cannot connect to http://my-tyk-instance.com:3000/


#1

I’ve followed along with the Vagrant install instructions without any errors but I can’t access http://my-tyk-instance.com:3000/ even though I have it set up in both my windows hosts file (Windows 10) and the Vagrant’s hosts file.

Can anyone point me to where I might be going wrong, please?


#2

Hi Boggin,

Our Vagrant instructions assume that you’re installing Tyk on a UNIX-like operating system which could explain why you’re having trouble. Can you please confirm that Vagrant is in fact running whenever you attempt to connect to your Tyk instance (you will need to have typed in the vagrant up command whilst in the directory that contains your Vagrant file at some point)? If it definitely is running, could you please confirm the error message you’ve received and provide the steps taken to install Tyk?

Kind regards,
Jess @ Tyk


#3

@jess The instructions have been followed to the letter.
https://tyk.io/tyk-documentation/get-started/with-tyk-on-premise/installation/install-tyk-pro-premise-vagrant/
The only difference would be:

% vagrant up --provider hyperv

It’s simply that when I try to browse to http://my-tyk-instance.com:3000/ there’s nothing there.

If it’s the case that others aren’t running this on W10 then I can imagine there’s some tricky Windows config that needs doing and no one else has ever come across it.


#4

Hi Boggin,

The fact that hostname is returning a blank page as opposed to an error message is quite peculiar. It may indicate either an issue with the Static Content settings on your machine or, if not, an issue with the way in which Vagrant’s Windows client handles static content so it may be worth looking into that.

Apart from that there are instructions on how to install Vagrant on Windows on Sitepoint, which might help, otherwise, you could try installing Tyk with Docker for Windows (but not the Docker Toolbox) instead.

Kind regards,
Jess @ Tyk


#5

Can you confirm that the vagrant box’ IP is actually 127.0.0.1, HyperV with Docker launches it on a different IP on Win10, I imagine it’s the same for Vagrant.

You might need to update your hosts file to point the hostname at the IP provided by HyperV


#6

Ah, yes :blush: You’re right, I hadn’t looked at the Vagrant IP.

As you point out, with Hyper-V on Windows 10, it’s on a virtual switch taking a DHCP address from my domain.

Thanks, peeps!