Unsupported-protocol-scheme-in-tyk-gateway-log


#1

Hi,

I have the exact same problem which is described here :

I think I have followed the steps from the latest documentation so I’d like some more clues.

In Tyk Dashboard, on portal configuration screen, I can see :

Error
Failed to create a new portal !

And in logs, every 5 seconds (maybe not related ?) :
Request failed: Get 1/register/node: unsupported protocol scheme “”


#2

Your Tyk gateway isn’t configured correctly - it can’t register with the dashboard.

In your connection strings you may have missed he http:// part of the policy and dashboard connection string settings

This is unrelated to the portal error. Once yu fix the gateway issue, you’ll need to go and make sure your portal is actually configured - did you follow the portal tutorial?


#3

Thanks for your answer.

To see the portal faster, I went through the docker installation instead :
https://tyk.io/docs/tyk-api-gateway-v-2-0/installation-options-setup/docker/

After following all steps and launching all steps, I launch setup.sh and it gives me username, password, and portal URL. When I try to login with provided username/password on the portal URL, it doesnt work (it works on IP:3000 though). When I go to “API catalogue” it says “error”.

Since the docker “getting started” is over, where should I go from here to be able to see some APIs in developper portal ?


#4

I am also facing a similar issue. I am setting up my tyk gateway and dashboard on Ubuntu. My dashboard is set up and I am able to configure API through dashboard. But when I make requests to the tyk URL via curl or PostMan (REST client), no data is returned. When I checked the logs, got the following error message in syslog

Nov 4 09:12:27 api-gateway-test1 tyk[30039]: time=“Nov 4 09:12:27” level=info msg=“Setting up Server”
Nov 4 09:12:27 api-gateway-test1 tyk[30039]: time=“Nov 4 09:12:27” level=info msg="–> Standard listener (http)"
Nov 4 09:12:27 api-gateway-test1 tyk[30039]: time=“Nov 4 09:12:27” level=info msg=“Registering node.”
Nov 4 09:12:27 api-gateway-test1 tyk[30039]: time=“Nov 4 09:12:27” level=error msg=“Request failed: Get 104.197.183.52/register/node: unsupported protocol scheme “””
Nov 4 09:12:32 api-gateway-test1 tyk[30039]: time=“Nov 4 09:12:32” level=error msg=“Request failed: Get 104.197.183.52/register/node: unsupported protocol scheme “””

The Get address has my IP instead of ‘1’ because I tried changing the connection string in db_app_conf_options (as suggested by Martin in an earlier discussion AWS setup of Tyk Gateway and Dashboard done..but not working). However, neither of the connection strings seem to be working.

Can anyone please guide me through this?


#5

You will need to visit the “settings” pages of your portal in order to initialise all the objects, this only needs doing once.

Open you dashboard, select the portal -> settings page (you’ll see a little warning), this will then set up your portal so it is visible. You don’t even need to save anything, just visit the page to initialise the base configuration.