Unable to setup uptime dashboard


#1

Hi,

I’m trying to setup the uptime dashboard. I checked the documentation added the following section into the tyk configuration file:

“uptime_tests”: {
“disable”: false,
“config”: {
“enable_uptime_analytics”: true,
“failure_trigger_sample_size”: 3,
“time_wait”: 30,
“checker_pool_size”: 50
}
}

I’ve setup the service discovery feature of the uptime test part of my API. The gateway logs show (IMO) that the returned JSON is correct:

time=“Mar 29 15:45:48” level=debug msg=“Checker host list”
time=“Mar 29 15:45:48” level=info msg=“Loading uptime tests…”
time=“Mar 29 15:45:48” level=debug msg=“Getting http://10.100.2.241:9876/health-endpoints?name=jetscan-screening&status=UP
time=“Mar 29 15:45:48” level=debug msg=“Parsing raw data: {\n “endpoints” : “[{\“url\”:\“http://10.100.2.115:8770/health\"}]"\n}”
time=“Mar 29 15:45:48” level=debug msg=“Got:{“endpoints”:”[{\“url\”:\“http://10.100.2.115:8770/health\"}]"}”
time=“Mar 29 15:45:48” level=debug msg=“Namespace: endpoints”
time=“Mar 29 15:45:48” level=info msg=”—> Adding uptime test: http://10.100.2.115:8770/health
time=“Mar 29 15:45:48” level=info msg="—> Adding uptime test: http://10.100.2.115:8770/health"
time=“Mar 29 15:45:48” level=debug msg="— Setting tracking list up"
time=“Mar 29 15:45:48” level=debug msg=“Reset initiated”
time=“Mar 29 15:45:48” level=debug msg="[HOST CHECKER] Checker reset queued!"
time=“Mar 29 15:45:48” level=debug msg=“Checker host Done”

However, I never see any activity in the “Service Uptime Dashboard”, although I’ve enabled the analytics.

Did I miss something ?

Thanks for you help!


#2

Hi

Do you have the uptime pump running?

In your pump.conf the block is:

"uptime_pump_config": {
    "collection_name": "tyk_uptime_analytics",
    "mongo_url": "mongodb://username:[email protected]{hostname:port},{hostname:port}/{db_name}"
  },
  "dont_purge_uptime_data": false

#3

Yes, coming from the official pump container:

“uptime_pump_config”: {
“collection_name”: “tyk_uptime_analytics”,
“mongo_url”: “mongodb://mongo:27017/tyk_analytics”
},
“dont_purge_uptime_data”: false

The mongo url should be OK as the stats by key & endpoints are correctly pumped.