Unable to ping Tyk-Dashboard ON-PREMISES link in Red Hat Unix system

Hi,
I have done all the setting of Tyk ON-PREMISES by following the below link

https://tyk.io/docs/get-started/with-tyk-on-premise/installation/redhat-rhel-centos/dashboard/

At step 8 when I am trying to open the link in browser but I am getting connection refused error.

Hi
For step 6 did you change the domain bind? And is the dashboard service running? Run sudo netstat -tlnp and check

Hi Josh,

  1. Yes at step 6 I have added the domain with system IP

py34env) [[email protected]*** yum.repos.d]# vi tyk_tyk-dashboard.repo
(py34env) [[email protected]*** yum.repos.d]# sudo yum -q makecache -y --disablerepo=’’ --enablerepo=‘tyk_tyk-dashboard’
(py34env) [[email protected]
** yum.repos.d]# sudo yum install -y mongodb-org tyk-dashboard redis
Loaded plugins: langpacks
Package mongodb-org-3.0.15-1.el7.x86_64 already installed and latest version
Package tyk-dashboard-1.7.1-1.x86_64 already installed and latest version
Package redis-3.2.12-1.el7.x86_64 already installed and latest version
Nothing to do
(py34env) [[email protected]*** yum.repos.d]# sudo service mongod start
Starting mongod (via systemctl): [ OK ]
(py34env) [[email protected]*** yum.repos.d]# sudo service redis start
Redirecting to /bin/systemctl start redis.service
(py34env) [[email protected]*** yum.repos.d]# sudo /opt/tyk-dashboard/install/setup.sh --listenport=3000 --redishost=localhost --redisport=6379 --mongo=mongodb://127.0.0.1/tyk_analytics --tyk_api_hostname=$HOSTNAME --tyk_node_hostname=http://localhost --tyk_node_port=8080 --portal_root=/portal --domain="/System IP/"
Listen Port = 3000
Redis Host = localhost
Redis Port = 6379
Redis PW =
Mongo URL = mongodb://127.0.0.1/tyk_analytics
API Hostname = ***
Tyk Node = http://localhost
Tyk Port = 8080
Dash Hostname = /System IP/
Portal Root = /portal
==> File written to ./tyk_analytics.conf
==> File copied to /opt/tyk-dashboard/install/…/tyk_analytics.conf
(py34env) [[email protected]*** yum.repos.d]# sudo service tyk-dashboard start
tyk-dashboard started

  1. when I checked the netstat -tlnp no Tyk-Dashboard is running, but the above terminal command not showing any error

I would check whther you have correctly passed the values to the configuration file. The tyk_analytics.conf file should be in opt/tyk-dashboard

Hi Josh,
Please find the configuration file

{
“listen_port”: 3000,
“tyk_api_config”: {
“Host”: “http://localhost”,
“Port”: “8080”,
“Secret”: “352d20ee67be67f6340b4c0605b044b7”
},
“mongo_url”: “mongodb://127.0.0.1/tyk_analytics”,
“shared_node_secret”: “352d20ee67be67f6340b4c0605b044b7”,
“license_key”: “”,
“page_size”: 10,
“admin_secret”: “12345”,
“redis_port”: 6379,
“redis_host”: “localhost”,
“redis_password”: “”,
“force_api_defaults”: false,
“notify_on_change”: true,
“license_owner”: “Your Name”,
“hash_keys”: true,
“email_backend”: {},
“hide_listen_path”: false,
“use_sentry”: false,
“sentry_code”: “”,
“sentry_js_code”: “”,
“show_org_id”: true,
“enable_duplicate_slugs”: true,
“host_config” : {
“override_hostname”: “/HOSTNAME/”,
“disable_org_slug_prefix”: true,
“enable_host_names”: true,
“hostname”: “/System IP/”,
“portal_domains”: {},
“portal_root_path”: “/portal”
},
“http_server_options”: {
“use_ssl”: false,
“certificates”: [
{}
]
},
“ui”: {
“login_page”: {},
“nav” : {},
“uptime”: {},
“portal”: {},
“designer”: {},
“languages”: {
“English”: “en”,
“Chinese”: “cn”,
“Korean”: “ko”,
“French”: “fr”
},
“default_lang”: “en”
},
“home_dir”: “/opt/tyk-dashboard”,
“identity_broker”: {
“enabled”: false,
“host”: {
“connection_string”: “http://localhost:3010”,
“secret”: “934893845123491238192381486djfhr87234827348”
}
},
“enable_aggregate_lookups”: true,
“aggregate_lookup_cutoff”: “01/07/2016”,
“oauth_redirect_uri_separator”: “;”,
“private_key_path”: “”
}

“hostname”: “/System IP/”,

This value has not populated which is why you cant see the dashboard on netstat - change it to the ip you want the dashboard to listen on, restart dashboard service and check netstat again to see if the service is listening.

Hi Josh,
“/System IP/” --> I have entered my system IP address only

“/HOSTNAME/" --> is my system host name

Is the service listening?

Nope its not listening