Unable to Create API Keys!


#1

Imported Google Group message. Original thread at: https://groups.google.com/forum/#!topic/tyk-community-support/OXWwG1Bs_iE Import Date: 2016-01-19 21:32:57 +0000.
Sender:Chris Lambert.
Date:Wednesday, 2 December 2015 22:26:29 UTC.

Hey folks!

Trying out Tyk here and after following the instructions at: https://tyk.io/v1.9/tutorial/* + reconfiguring my listening port to 8888, i’m able to use the dashboard and do most things, including creating an API, however when I attempt to test it per the “create an api” portion of the tutorial I’m running into problems trying to create an API key.

Using the Dashboard yields: http://screencast.com/t/TaaVOaOh

Using the other approach gives the same:

{
“Message”: “Failed to save new session object to Tyk: Failed to unmarshal error: invalid character ‘<’ looking for beginning of value”,
“Meta”: null,
“Status”: “Error”
}

Anyone able to assist? I’m probably missing something simple but after some playing it’s not obvious to me yet.


#2

Imported Google Group message.
Sender:Martin Buhr.
Date:Wednesday, 2 December 2015 22:36:14 UTC.

Hi Chris,
take a look at the tyk_analytics.conf file and make sure it has the correct port set for the gateway configuration, the dashboard (and dashboard API) need to see the Tyk node, and if the port was changed for the gateway, it will need to be matched in the dashboard config.
So if your gateway is on 8888 and the dash is in 3000 then the dashboard config needs to be amended so that it can see the gateway on that port, if it’s calling 8080 then it might be getting some HTML back which explains your error.
That’s just an assumption though - would need to see the Tyk.conf and tyk_analytics.conf files to be sure - basically the settings in tyk.conf need to be reflected in tyk_analytis.conf.
Hope that helps - might need to be something we address in the setup scripts.
Are you installing on docker or vagrant or a server?
Cheers,
Martin