Tyk support rpc


I am busy trying Tyk out. I have installed the docker. I have bootstrapped. When I try create an api it saves, seems fine. But it seems to be creating a rest api, I require a rpc api. Does tyk support rpc api? If yes how do I get that part working.

Appreciate any feedback.


Hi @loosh,

Welcome to the community :tada:

Please have a read here and here, and let us know if it helps?


I got the rpc to work.

I actually found it is a problem with the install. If I use docker pro demo and follow these steps Docker Pro Demo it doesn’t work. No api worked at all.

I then used GitHub - TykTechnologies/tyk-demo: Tyk Docker Demo with full Pro Tyk Installation and more! and seems to have worked great, but cant get the portal to work here. Any suggestions?


Hey @loosh - when you say the portal doesn’t work, can you give me more details? Is there an error message or similar?


So when I use docker pro demo a basic api using http://httpbin.org/ keeps returning not found. This github seems to have instructions for the portal but due to base not working I didnt look at portal there. I have set hostnames, etc. But doesn’t work, but also running in cloud vps where guide seems to assume you doing on local machine.

The tyk-demo the base api works, but this github has no instructions for the portal. Inside TYK website, top right has option to open portal. Your developer portal → open your portal. It then tries open which is not correct. So I assume i need to configure, setup, or do something. But no clear instructions found for this repo


You certainly do need to set it up.
There’s a step by step guide in the docs under “getting started”

Can you walk through this and let us know if you get stuck anywhere:

@James - thanks for the info. I did those steps now. Never saw those. However the page does not open. Opens blank still.

Have you tried it with GitHub - TykTechnologies/tyk-demo: Tyk Docker Demo with full Pro Tyk Installation and more!

I find the instructions on documentation is mainly for Docker Pro Demo but just doesnt seem to work on my side.

It will work with either - can you describe or screen grab what you are seeing?
You say it ‘opens blank’ - do you get a 404 or a blank page, or a title and missing docs?
Is the Tyk dashboard working otherwise? It’s just the developer portal causing problems?

Hi @James

The error it shows is “the site cant be reached”. I set the domain to http://tyk-portal.localhost/portal. Also tried replacing tyk-portal.localhost with ip address. Also installed ubuntu remote desktop so I could login and try there by using localhost. No luck. Followed the steps in your link and was hoping it would work.

Any ideas?

Ok, we should check a few things first, before we move onto the portal:

You installed tyk using the repo you linked to above. Were you then able to access the dashboard? At what URL did you access the dashboard?


Hi @James

Used tyk-demo repo

This repo creates all entries in /etc/hosts. The machine is running on a vps

I then access from my machine using “http://<my_ip_address>:3000”. Hope this helps.

Yes, able to get into the dashbaord, link to my own rpc, add policies, etc. Interact from postman on my machine with Tyk.

Just the portal I can not get working.

Did you try following step 2 and step 3 of the self managed section in the doc @James shared?

I have time zone issues in pasting the screen shot but the steps are below:

Step 2: Initialise all your portal settings

By default there is no Portal configured, you need to configure from the Portal settings screen, even if you don’t want to change the options. Select Portal Management > Settings. The notification view on the right will say that no configuration was detected so it was created. Your Portal won’t work without this step, so it’s important.

That’s it, now you need to create the home page.

Step 3: Create the home page

From Pages" click Add Page and give it any title you like (e.g. “Welcome”) and select Default Home Page Template from the Page Type drop-down list. Ensure Check to make this page the home page is selected.

Save the page.

If you still can’t see anything after this, then can you share your dashboard/analytics configuration. The host_config.portal_xxx is what is needed

Hi @Olu

Yes, did step 2 and 3. In step 2 I even just added e-mail and saved.

Step 3, did that and clicked check box.

For some reason I cant paste screen shots here, would of preferred to paste so you can see.

Where would I find the file you requesting? Not I amd using teh Tyke Demo repo and not the one in the documents.


There is some date and time issue restricting screenshots.

The file should be somewhere called tyk_analytics.conf. Depending on how you may have modified your setup, it may be named something different or you might be using environment variables to set it up. Example of what we are looking for is

    "host_config": {
		"disable_org_slug_prefix": true,
		"enable_host_names": false,
		"generate_secure_paths": false,
		"hostname": "",
		"override_hostname": "",
		"portal_domains": {},
		"portal_root_path": "/portal",
		"secure_cookies": false,
		"use_strict_hostmatch": false

If environment variables then it should be anything prefixed with TYK_DB_HOST

But, you mentioned the dashboard works fine. So could you put insert /portal in the same dashboard URL to check if the developer portal is bootstrapped.

If you see home page not found then, kindly follow this tutorial Configure your Developer Portal - YouTube. The first 3 minutes should suffice

Let us know how it goes

@loosh Any luck?

I see some of your posts were flagged by the system because you tried to link a github link.