Tyk Panic (right after Docker-style install)


#1

Right after a full Tyk install using Docker images, when I try to submit registration form from the portal, I get :

ERROR 2016/10/13 14:36:57.523890 panic_handler.go:26: PANIC
URL: /57ff9b8310215a0001000007/portal/register/
ERROR: interface conversion: interface is nil, not string

To see these logs, I did :
sudo docker logs --tail=100 --follow tykquickstart_tyk_dashboard_1


#2

Hi, how did you setup the dashboard?

Do other features work?


#3

Hi, I’ve setup everything exactly as described in the documentation :
https://tyk.io/docs/tyk-api-gateway-v-2-0/installation-options-setup/docker/

When I connect to the gateway or portal, I’m using IP:3000 though, not www.tyk-portal-test.com:3000 since I have no browser on the local server, is it important ?

About “other features” I don’t know why u mean, I’m just trying to see some APIs through developer portal and if possible interact with them with some “try it out” UI, are there some other main features ?


#4

How did you setup the gateway? Is it running?

Have you tried using the domain?


#5

mmmm same answer as the one to “how did you setup the dashboard?” (exactly as described in the documentation :
https://tyk.io/docs/tyk-api-gateway-v-2-0/installation-options-setup/docker/)
or maybe I don’t know what you mean.

Yes the gateway is running fine.

Have you tried using the domain ?

What do u mean ? www.tyk-portal-test.com is not declared in any DNS, it’s only known from local server and I have no browser on local server.

I have a question for you : have you tried the docker install ? does it run fine for you without any additional configuration ?


#6

I see, the portal requires a domain to work properly, even if it’s one that you setup locally!

Check the first step: https://tyk.io/docs/tyk-api-gateway-v-2-0/installation-options-setup/docker/


#7

Ok, so I added www.tyk-portal-test.com to my c:\windows\system32\drivers\etc\hosts bound to my server IP but when I try to register a new user through portal/register it has quite the same result.

Here is a more complete log :

time="Oct 14 13:13:36" level=warning msg="No developer quota set - bypassing"
time="Oct 14 13:13:36" level=warning msg="Checking developer quota: true"
time="Oct 14 13:13:36" level=warning msg="No developer quota set - bypassing"
time="Oct 14 13:13:36" level=warning msg="No portal configuration found"
time="Oct 14 13:13:36" level=info msg="Updated dev count"
time="Oct 14 13:13:36" level=info msg="Email notifications disabled, skipping Send()"
ERROR 2016/10/14 13:13:36.712961 panic_handler.go:26: PANIC
URL: /57fe4c7510215a0001000001/portal/register/

#8

Ok, I was trying to give a chance to Tyk in my evaluation of open source API management tools for my company (EDF - Electricité De France), but if the most straight-forward way of installation is not operational, and just no one cares, I’ll just have to recommend a more mature tool like WSO2 (you unzip it, your start it, and you can add your API right after that, the support is only needed for advanced use cases).


#9

Hi Tristan,

I’m sorry that the community forum didn’t provide a response in the time that you were expecting it in, please remember that this is a community forum, and where possible, we try to reply to everyone in a timely basis (but not necessarily over the weekend) :slight_smile:

As for the issue you are facing, the problem is right there in the logs:

To fix it, you simply need to visit the Portal -> Settings page in your dashboard (you will see a notification that says that a configuration has been created for you), this creates your portal definition and gets the whole system bootstrapped. We’ll update the docs for this step as it does trip some users up.

You will need to delete and re-create your portal catalogue entries though.

Tyk is an API Management platform of which the portal is one small part, you do not need the portal, the catalogue or any of those features to manage APIs or tokens (in fact, it’s one of the more complex and tricky ways to get started!), so it might be the case that your evaluation started at the more complex end of Tyk.

Cheers,
Martin


Docker Quickstart with Docker for Mac