Tyk not returning access tokens. : NOAUTH Authentication required


#1

Imported Google Group message. Original thread at: https://groups.google.com/forum/#!topic/tyk-community-support/rMguTmY6pws Import Date: 2016-01-19 21:40:07 +0000.
Sender:[email protected].
Date:Tuesday, 5 January 2016 12:43:25 UTC.

Hey Martin,

We’ve successfully configured tyk and the oauth flow.
Everything seemed to be fine and suddenly tyk stopped responding with the auth codes.


This is the error we keep getting :
time=“2015-12-30T11:04:17Z” level=info msg="[OAuth] Notifying client host"
time=“2015-12-30T11:04:17Z” level=info msg="[OAuth] Notifying client host"
time=“2015-12-30T17:00:26Z” level=error msg=“Multi command failed: NOAUTH Authentication required.”
time=“2015-12-30T17:00:36Z” level=error msg=“Multi command failed: NOAUTH Authentication required.”
time=“2015-12-30T17:00:46Z” level=error msg=“Multi command failed: NOAUTH Authentication required.”


If you notice , everything was fine and suddenly something went wrong.

We spent some time debugging this and we figured out that redis was securing keys with a password.
We hadn’t over-ridden the default tyk password for redis. It was “” - as is.

Even logging through redis-cli was asking for a password.

The work-around that we implemented was - Restarting Redis and creating the keys again. But I’m afraid this won’t suit our needs on production environment.

There are two questions on our minds :

  1. Why didnt redis seek a password right frm the beginning
  2. If at all we find ourselves in a similar situation later, how do we fix it at the earliest.

Regards,
Balaji


#2

Imported Google Group message.
Sender:Martin Buhr.
Date:Tuesday, 5 January 2016 15:58:51 UTC.

Hi Balaji,

I’m really not sure, Tyk is a just a Redis client, it does what the DB asks for.

I would suggest reading the documentation for Redis, or going to the Redis mailing list and asking there as this forum isn’t really the best place to be asking about Redis internals :slight_smile:

Many thanks,
Martin

  • show quoted text -

  • show quoted text -


You received this message because you are subscribed to the Google Groups “Tyk Community Support” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To view this discussion on the web, visit https://groups.google.com/d/msgid/tyk-community-support/ed85abe7-4807-4ed5-8fad-97ca27437d6c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.