Tyk Day 2 - Need help for request key in Dev.Portal


#1

Today was my day2 of setting up Tyk.

Thanks to help from martin, i was able to setup the gateway and dashboard. I was also able to open the developer portal.

Now i´m at the point where a logged user who signed up before tries to create a key. When the user request the key the browser never came back from this key request.

In the log file i saw these entries:
[[90m[Jun 8 17:07:22]^[[0m ^[[31mERROR^[[0m Trying to create token from cvatalogue with no auth types! No valid API found!^M
^[[90m[Jun 8 17:07:22]^[[0m ^[[31mERROR^[[0m Something went wrong, couldn’t get Api detail^M
^[[90m[Jun 8 17:07:22]^[[0m ^[[31mERROR^[[0m not found^M
^[[90m[Jun 8 17:19:31]^[[0m ^[[32m INFO^[[0m Sending notification{PolicyChanged 5756f3cd6aa51b0b60000001}^M
…repeats…

I really tried to interpret the issue from the logs and to fix it. I set the API in the catalog to Auth Token, Auth Key Header Name to Authorization, but still get the same effect that i´m not able to generate a user key in the developer portal.

The strange thing is that in the backend / dashboard i see that there were keys generated from the developer portal.

Anyone had also this issue?

Thx


#2

hmmm, this kind of thing only happens with policies where auth modes are mixed or open API’s are included in the ACL or the attached policy is invalid in some way.

What policy have you attached to the catalogue entry?
Does this policy exist?
Do the API’s referenced in the policy all exist?

Check for missing API entries or change API IDs in your policy, and remember that API’s in a policy shouldn’t be mixed auth mode, they should all share the same auth method.


#3

I will try it again. As i said i can see the key request in the backend and when i try to approve it from the backend, the backend is freezing with the orange line on top and the loading circle.

The javascript console posts this:
XMLHttpRequest cannot load http://example1:5000/socket.io/?chan=ui_notifications.5756f3cd6aa51b0b60000001&EIO=3&transport=polling&t=1465424356814-64. Origin http://example1:3000 is not allowed by Access-Control-Allow-Origin.

It seems that i have an cors problem cause different ports.

I remember that i have seen a flag cors enable. I enable the CORS in the API Designer, but i think this has nothing todo with this error.

I think i have to spend much days to get it working. Any idea to fix this would be great.

Thx!


#4

That CORS error is actually for a websocket connection so you get system notifications, it’s unrelated to your bug.

It’s something you’ll need to resolve, but not immediately.

The issue you are facing with he key request trying to be approved is definitely policy related.

May I ask what auth method you are using for the API? Only basic auth and Bearer token are supported at the moment.


#5

I tried again some hours without finding the issue. I simple set API first, then the policy. As auth i used Basic Auth. I register then a user in the portal and request a new api and browser freezes again without not coming back.

In the dashboard log file i saw only see this one line:
^[[90m[Jun 9 20:55:43]^[[0m ^[[33m WARN^[[0m Generating username and password^M

Do you have any idea how i can debug or create more logs to find out whats going wrong?

Thanks a lot for your great support. I really want to use typ commercial and it seems that i need some helping hands before i can start. Is it maybe possible to get commercial support on our demo machine to learn what we are doing wrong?


#6

Ultimately the gateway does the key creation bit, what do your gateway logs say?

Unfortunately the gateway doesn’t have a log level for debug output that can be controlled int he command line yet.

We do offer commercial support to get up and running:

https://tyk.io/premium-support/


#7

From the gateway log file i only can see this entries, they repeat after some time. I will sign up the support contract and hope that we can get up and run this thing :slight_smile:

^[[90m[Jun 11 06:27:44]^[[0m ^[[31mERROR^[[0m Request failed: Get 1/register/node: unsupported protocol scheme “”^M
^[[90m[Jun 11 06:27:49]^[[0m ^[[31mERROR^[[0m Request failed: Get 1/register/node: unsupported protocol scheme “”^M
^[[90m[Jun 11 06:27:54]^[[0m ^[[31mERROR^[[0m Request failed: Get 1/register/node: unsupported protocol scheme “”^M
^[[90m[Jun 11 06:27:59]^[[0m ^[[31mERROR^[[0m Request failed: Get 1/register/node: unsupported protocol scheme “”^M


#8

Hi Gary,

I’ve gotten in touch with you directly via our support portal to give the diagnosis.

Cheers,
Martin