Tyk-dashboard service gone after upgrading to 1.2


#1

I have upgraded tyk-dashboard from 1.1 with:
sudo yum upgrade tyk-dashboard
and after the successive completion of process there is no tyk-dashboard service.

I tried executing the setup.sh script but this didn’t change anything…

Should i try ‘sudo yum reinstall tyk-dashboard’?

Thanks a lot.

Nikos


#2

You may want to re-install. It might have also blitzed your tyk_analytics.conf file.


#3

Martin, i had kept a backup of my tyk_analytics.conf file and corrected the newly created one on server. Strange thing is, that dashboard keeps playing but says version 1.1.0. I’ll reboot my system and check what happens. In case there is no tyk-dashboard service I’ll try to reinstall. Keep you informed…

Nikos


#4

Well the situation is as follows:

  1. I reinstalled tyk-gateway 2.2.0.28
  2. Executed the setup.sh and completed according to previous tyk.conf the newly, the generated tyk.conf
  3. Reinstalled tyk-dashbord 1.2
  4. Executed the setup.sh and completed according to previous tyk-analytics.conf, the generated tyk-analytics.conf
  5. started successfully the tyk-gateway service
  6. Started successfully the tyk-dashboard service
  7. Started successfully the tyk-pump service

They seem to be running ok. But when i hit the ‘http://tyk.ilsp.gr:3000/’ url a get a grey page with an empty white div. What went wrong? I could send you the logs and the conf files.


#5

Problem solved! It was a clear cache problem! After rebooting server and clearing the cache everything worked normal! Thanks