TYK Dashboard installation issue

[[email protected] opt]# sudo /opt/tyk-dashboard/install/bootstrap.sh XXX.XXX.XXX.XXX
Found Python interpreter at: /bin/python3

Creating Organisation
ERROR: Unable to connect to the Dashboard. Please check that you are using the correct hostname.
[[email protected] opt]#

Hi! Seems like a connection issue.

Try the following command (replace x.x.x.x with your host IP address or host name):

$ curl -v http://x.x.x.x:3000

Regards

This post was flagged by the community and is temporarily hidden.

This post was flagged by the community and is temporarily hidden.

[[email protected] opt]# firewall-cmd --list-ports
3000/tcp 8080/tcp 6379/tcp 27017/tcp

This post was flagged by the community and is temporarily hidden.

The connection refused message indicates that the Dashboard service is not running. Please can you check that the Dashboard service is running on this host?

If it is running, then you also need to check that it is running on port 3000. Please check that the listen_port setting in the /opt/tyk-dashboard/tyk_analytics.conf file is set to 3000.

Thank you for your reply David.

Listen port Configuration parameter as below.
Also, dashboard service status was running and active.

[[email protected] install]# cat tyk_analytics.conf | grep -i listen
“listen_port”: 3000,
“hide_listen_path”: false,

Still problem persists.

This is unusual, if the service is running and is listening on port 3000 then it should respond to a request.

Perhaps there is a problem with the Dashboard service. Can you restart the service and then check the contents of the log file? By default, log files are stored in /var/log or /var/log/upstart. Please check the log file for errors.

Log files Output:

Jul 31 23:43:22 ip-172-31-8-80 tyk[26651]: time=“Jul 31 23:43:22” level=error msg=“Error trying to get TTL: dial tcp 172.31.8.80:6379: connect: connection refused”

Jul 31 23:43:24 ip-172-31-8-80 tyk[26651]: time=“Jul 31 23:43:24” level=info msg=“Waiting for Redis connection pools to be ready” currRetry=3
Jul 31 23:43:27 ip-172-31-8-80 tyk[26651]: time=“Jul 31 23:43:27” level=error msg=“Waiting for Redis connection pools failed”
Jul 31 23:43:27 ip-172-31-8-80 tyk[26651]: time=“Jul 31 23:43:27” level=fatal msg=“Redis connection pools are not ready. Exiting…”

Jul 31 23:43:27 ip-172-31-8-80 systemd[1]: tyk-gateway.service: Main process exited, code=exited, status=1/FAILURE
Jul 31 23:43:27 ip-172-31-8-80 systemd[1]: tyk-gateway.service: Failed with result ‘exit-code’.
Jul 31 23:43:27 ip-172-31-8-80 systemd[1]: tyk-gateway.service: Service RestartSec=100ms expired, scheduling restart.
Jul 31 23:43:27 ip-172-31-8-80 tyk[26660]: time=“Jul 31 23:43:27” level=warning msg="File descriptor limit 1024 too low for production use. Min 80000 recommended.

All the components Dashboard, Gateway, Pump , Redis and Mongod status is running and active.

[[email protected] ~]# sudo service redis status
Redirecting to /bin/systemctl status redis.service
● redis.service - Redis persistent key-value database
Loaded: loaded (/usr/lib/systemd/system/redis.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/redis.service.d
└─limit.conf
Active: active (running) since Mon 2019-07-29 15:16:19 UTC; 2 days ago
Main PID: 3184 (redis-server)

[[email protected] ~]# sudo service tyk-dashboard status
Redirecting to /bin/systemctl status tyk-dashboard.service
● tyk-dashboard.service - Tyk API Dashboard
Loaded: loaded (/usr/lib/systemd/system/tyk-dashboard.service; disabled; vendor preset: disabled)
Active: active (running) since Thu 2019-08-01 00:07:23 UTC; 2s ago
Main PID: 29407 (tyk-analytics)
Tasks: 5 (limit: 4998)
Memory: 8.9M
CGroup: /system.slice/tyk-dashboard.service
└─29407 /opt/tyk-dashboard/tyk-analytics --conf /opt/tyk-dashboard/tyk_analytics.conf

Aug 01 00:07:23 ip-172-31-8-80.us-east-2.compute.internal systemd[1]: tyk-dashboard.service: Service RestartSec=100ms expired, scheduling restart.
Aug 01 00:07:23 ip-172-31-8-80.us-east-2.compute.internal systemd[1]: tyk-dashboard.service: Scheduled restart job, restart counter is at 131.
Aug 01 00:07:23 ip-172-31-8-80.us-east-2.compute.internal systemd[1]: Stopped Tyk API Dashboard.
Aug 01 00:07:23 ip-172-31-8-80.us-east-2.compute.internal systemd[1]: Started Tyk API Dashboard.
Aug 01 00:07:23 ip-172-31-8-80.us-east-2.compute.internal tyk-analytics[29407]: time=“Aug 1 00:07:23” level=info msg="Using /opt/tyk-dashboard/tyk_analytics.conf for >
Aug 01 00:07:23 ip-172-31-8-80.us-east-2.compute.internal tyk-analytics[29407]: time=“Aug 1 00:07:23” level=warning msg="Default tyk_api_config.secret 352d20ee67be67> Aug 01 00:07:23 ip-172-31-8-80.us-east-2.compute.internal tyk-analytics[29407]: time="Aug 1 00:07:23" level=warning msg="Default admin_secret12345should be change> Aug 01 00:07:23 ip-172-31-8-80.us-east-2.compute.internal tyk-analytics[29407]: time="Aug 1 00:07:23" level=warning msg="Default shared_node_secret352d20ee67be67f63>
Aug 01 00:07:23 ip-172-31-8-80.us-east-2.compute.internal tyk-analytics[29407]: time=“Aug 1 00:07:23” level=info msg=“Connecting to MongoDB: [172.31.8.80]”