Tyk dashboard API creation And test environment


#1

Hello everyone,
I deployed the Tyk dashboard and Tyk gateway and Tyk pump on a test machine, version tky-dashboard-1.6.1-1.x86_64, trk-gateway-2.6.1-1.x86_64, tink-pump-0.5. 2-1.x86_64, also deployed java web application on the same test machine tomcat 7, I created an API on the Tyk dashboard, this API is the login address of the javaweb application. I access the login page through the URL. After successfully logging in, Tyk dashboard does not record my login information. I don’t know if there is a problem with my environment configuration or API creation. I need help, thank you.

To add, I created the API through the Tyk dashboard, got the API URL, accessed through this API URL, and returned 404 page not found , but checked UPTIME TESTS, and Target breakdown has a successful access record in the Service uptime dashboard.


#2

The API I created is as follows:
API URL: http://10.132.29.202/jingmaotest/
{
“api_definition”: {
“api_id”: “a3fdab35a0e846c758d1a7d67813953f”,
“upstream_certificates”: {},
“use_keyless”: true,
“enable_coprocess_auth”: false,
“custom_middleware”: {
“pre”: [],
“post”: [],
“post_key_auth”: [],
“auth_check”: {
“name”: “”,
“path”: “”,
“require_session”: false
},
“response”: [],
“driver”: “”,
“id_extractor”: {
“extract_from”: “”,
“extract_with”: “”,
“extractor_config”: {}
}
},
“disable_quota”: false,
“custom_middleware_bundle”: “”,
“cache_options”: {
“enable_cache”: false,
“enable_upstream_cache_control”: false,
“cache_timeout”: 60,
“cache_response_codes”: [],
“cache_all_safe_requests”: false
},
“enable_ip_blacklisting”: false,
“tag_headers”: [],
“pinned_public_keys”: {},
“domain”: “”,
“openid_options”: {
“providers”: [],
“segregate_by_client”: false
},
“active”: true,
“config_data”: {},
“notifications”: {
“oauth_on_keychange_url”: “”,
“shared_secret”: “”
},
“auth”: {
“auth_header_name”: “”,
“use_certificate”: false
},
“check_host_against_uptime_tests”: false,
“blacklisted_ips”: [],
“hmac_allowed_clock_skew”: -1,
“uptime_tests”: {
“check_list”: [],
“config”: {
“service_discovery”: {
“use_discovery_service”: false,
“query_endpoint”: “”,
“use_nested_query”: false,
“parent_data_path”: “”,
“data_path”: “”,
“cache_timeout”: 60
}
}
},
“enable_jwt”: false,
“name”: “jingmaotest”,
“slug”: “jingmaotest”,
“oauth_meta”: {
“allowed_access_types”: [],
“allowed_authorize_types”: [],
“auth_login_redirect”: “”
},
“CORS”: {
“enable”: false,
“max_age”: 24,
“allow_credentials”: false,
“exposed_headers”: [],
“allowed_headers”: [],
“options_passthrough”: false,
“debug”: false,
“allowed_origins”: [],
“allowed_methods”: []
},
“event_handlers”: {
“events”: {}
},
“proxy”: {
“target_url”: “http://10.132.29.202:8011/JMBI/”,
“service_discovery”: {
“cache_timeout”: 0,
“parent_data_path”: “”,
“query_endpoint”: “”,
“use_discovery_service”: false,
“_sd_show_port_path”: false,
“target_path”: “”,
“use_nested_query”: false,
“data_path”: “”,
“port_data_path”: “”
},
“check_host_against_uptime_tests”: false,
“transport”: {
“ssl_ciphers”: [],
“ssl_min_version”: 0,
“proxy_url”: “”
},
“target_list”: [],
“preserve_host_header”: false,
“strip_listen_path”: false,
“enable_load_balancing”: false,
“listen_path”: “”
},
“client_certificates”: [],
“use_basic_auth”: false,
“version_data”: {
“not_versioned”: true,
“versions”: {
“Default”: {
“name”: “Default”,
“expires”: “”,
“override_target”: “”,
“extended_paths”: {
“cache”: [],
“method_transforms”: [],
“hard_timeouts”: [],
“do_not_track_endpoints”: [],
“track_endpoints”: [],
“virtual”: [],
“transform”: [],
“ignored”: [],
“transform_headers”: [],
“white_list”: [],
“transform_response”: [],
“size_limits”: [],
“url_rewrites”: [],
“transform_response_headers”: [],
“circuit_breakers”: [],
“black_list”: []
},
“global_headers”: {},
“global_headers_remove”: [],
“global_size_limit”: 0,
“use_extended_paths”: true
}
},
“default_version”: “”
},
“use_standard_auth”: false,
“disable_rate_limit”: false,
“definition”: {
“key”: “x-api-version”,
“location”: “header”
},
“use_oauth2”: false,
“allowed_ips”: [],
“org_id”: “5cc27796cc30090cdfc7b9f3”,
“enable_ip_whitelisting”: false,
“global_rate_limit”: {
“rate”: 0,
“per”: 0
},
“enable_context_vars”: false,
“tags”: [],
“strip_auth_data”: false,
“id”: “5cc573e2cc30090e9d682f85”,
“enable_signature_checking”: false,
“use_openid”: false,
“enable_batch_request_support”: false,
“response_processors”: [],
“use_mutual_tls_auth”: false,
“auth_provider”: {
“name”: “”,
“storage_engine”: “”,
“meta”: {}
},
“do_not_track”: false,
“dont_set_quota_on_create”: false,
“expire_analytics_after”: 0,
“session_lifetime”: 0
},
“hook_references”: [],
“is_site”: false,
“sort_by”: 0
}