Requested endpoint is forbidden error

I am new to Tyk setup. I tried to configure the api url by reading the documentation.

Core settings:
API Name - Test API
Listen path - /test-api/
Target URL - Dog API
Authentication - Keyless

Endpoint designer:
Method - GET
Path - breeds/list/all
Plugin - Whitelist

“error”: “Requested endpoint is forbidden”

I am not sure where I am doing wrong. Can you please help me on this.

Can anyone please help me on this.

You have a white list enabled - they are very strict, it could be that the match you have specified does not match exactly the request you are making.

Have you tried not using a white list? tyk proxies everything by default, so this should only be needed when you have properly got the proxy working.

I tried with others also. I am getting the same error.

Requested endpoint is forbidden" api_id=some_id org_id=some_id path=“/” server_name=“” user_id= user_ip=some_ip

which plugin do you suggest. It is completely ignoring the path mentioned in endpoint designer.

You have set /breeds/all as a the white list

But you are asking for /

You can try removing the starting slash that migh match better.

Try just using “Track endpoint”, but if the match is wrong, that won’t trigger either.