Problem upgrading to newer version

Every time i need to upgrade to a newer version of a package (either tyk-gateway or tyk-dashboard or both like this new one) i face the same problem. Having gateway 2.2, dashboard 1.2 and pump 0.3, i had to upgrade both 3 packages.

Before I start the upgrade process, I stop all the tyk services.
Next, I update the packages with:

sudo yum update tyk-package

and run the to produce the new configuration file for each packet. Then I edit the new conf file with proper values and try to start the service.

sudo service tyk-package start

Every time i get the ‘service unknown’ error.

So every time i have to reinstall the package:
sudo yum reinstall tyk-package

and run again the script to recreate the conf file, then edit it and start again the corresponding service. Then everything runs smoothly.

Is it somethething i am doing wrong in the upgrading process?


I don’t think our upgrade scripts work as they are supposed to, we need to investigate this. At the moment the best way to upgrade is to re-install but ensure you backup your conf files.

I always keep backups of my conf files since update overwrites the old ones.

Just to to let you know, I run my tyk on Centos 6.5

Thanks Martin

Hi Martin,

After using successfully for a long time period the on-premises tyk version (tyk-gateway: 2.4.2., tyk-dashboard: 1.4.2 and tyk-pump: 0.4.2), I decided it was time to upgrade to new versions. After updating both 3 packages with yum command, I came across the fact that services are gone (‘service unknown’). Being used to having this problem, I tried ‘yum reinstall’ for each one of the packages. Then I run the script and then edited the corresponding conf files. But this time the problem with the ‘service unknown’ still appeared.

I tried setting up first tyk-dashboard but there was no difference, I still got the ‘service unknown’ error

I noticed that in each install catalog the are new script files (,,,, So my question is, should I run any of this scripts before running the script? Should I have done updates to redis (my current version is 3.2.11)? Is there any other prerequisite I should update first?

Thanks in advance,