Master keys disallowed in configuration, key not added


#1

Imported Google Group message. Original thread at: https://groups.google.com/forum/#!topic/tyk-community-support/YiN0ow4V7Cs Import Date: 2016-01-19 21:13:15 +0000.
Sender:Marcel Montel.
Date:Wednesday, 20 May 2015 08:10:16 UTC+1.

Hello.

How would i turn on the option to allow master keys in the configuration? A member of my team is trying to add keys through the API and gets this error message

“2015-05-19T15:28:13Z” level=error msg=“Master keys disallowed in configuration, key not added”.

Thanks


#2

Imported Google Group message.
Sender:Marcel Montel.
Date:Wednesday, 20 May 2015 08:34:10 UTC+1.

looking at https://github.com/lonelycode/tyk/blob/master/api.go it seems to require AllowMasterKeys, but where in the config?
should it be added to “tyk_api_config”: {} ?

  • show quoted text -

#3

Imported Google Group message.
Sender:Martin Buhr.
Date:Wednesday, 20 May 2015 08:37:35 UTC+1.

Hi Marcel

It means that the key they are trying to add does not have access control permissions set, if these are left unset, keys will have access to all (now and future) API’s in the system. It is strongly recommended not to enable this option and instead to specify an API and version in the access rights section of the key being created.

If you must add master keys then you can change this option in the tyk.conf file by changing the allow_master_keys parameter, akll the configuration options are described in the configuration section of our documentation.

Cheers,
Martin

  • show quoted text -