Manual installation

Imported Google Group message. Original thread at: https://groups.google.com/forum/#!topic/tyk-community-support/qExxAAvxhwc Import Date: 2016-01-19 21:27:21 +0000.
Sender:Kasinath Nalla.
Date:Friday, 16 October 2015 20:30:17 UTC+1.

Hi Martin,
Thanks all for your help…
I have done the demo with vagrant and docker… They loved it…
Now I am running into another issue… Some reason It’s not working

Here is the log

[[email protected] tyk.linux.amd64-1.8.3.2]$ sudo ./tyk --conf=tyk.conf
[sudo] password for knalla:
INFO[0000] Creating new Redis connection pool
INFO[0000] Setting up Server
WARN[0000] --> Standard listener (http)
INFO[0000] Detected 0 APIs
INFO[0000] Loaded 0 policies
INFO[0000] Gateway started (v1.8.3.2)
INFO[0000] --> Listening on port: 8080

[[email protected] tyk-analytics-v0.9.6.5]$ ./tyk-analytics
INFO[0000] Loading configuration from ./tyk_analytics.conf
INFO[0000] Creating new Redis connection pool
INFO[0000] Tyk Analytics Dashboard 0.9.6.5
INFO[0000] Copyright Martin Buhr 2015
INFO[0000] https://www.tyk.io
INFO[0000] Listening on port: 3000

I have mongo db and redis started.

When I try to login, I am getting

Error 305 Moved Permanently…

Do you know whats going on here?

Thanks again for your help Martin…

Imported Google Group message.
Sender:Martin Buhr.
Date:Sunday, 18 October 2015 19:21:47 UTC+1.

Hi Kasinath,

I’m afraid not - the OAuth flows are quite complicated (as you would expect) - the simplest thing I would suggest is to use the password OAuth flow - it’s much simpler than standard OAuth.

If you look at the change log there’s some instructions.

Cheers,
Martin

Imported Google Group message.
Sender:Kasinath Nalla.
Date:Friday, 16 October 2015 21:04:27 UTC+1.

Hi Kasinath,
Glad to hear it :slight_smile:
What URL are you using to log in with - sometimes errors like that are just down to a missing slash (/)?
Cheers,
Martin

Imported Google Group message.
Sender:Martin Buhr.
Date:Friday, 16 October 2015 21:20:08 UTC+1.

Hi Martin,
Since they liked it they wanted me to set it up in one of our vm so we can use it part of our development and we can test it…

So I tried to set it up on linux. and I used
http://lpv-ecisdev129:3000/ then I can see the login screen but when i give wrong credentials then it shows as wrong credentials… but when I give right credentials I am getting error code 305…

Your help will be appreciated
Thanks,
Kasinath

  • show quoted text -

Imported Google Group message.
Sender:Kasinath Nalla.
Date:Friday, 16 October 2015 21:34:13 UTC+1.

It’s quite odd.

Did you create an organisation and a user?

Is the dashboard process showing any errors or output when you try the login or just what you sent with your first message?

Can you send a screenshot of the error in the browser?

Are you accessing the VM via a proxy or firewall or something else that could be influencing the request?

Cheers,
Martin

  • show quoted text -

  • show quoted text -


You received this message because you are subscribed to the Google Groups “Tyk Community Support” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To view this discussion on the web, visit https://groups.google.com/d/msgid/tyk-community-support/ea2c111d-5abe-42a3-8451-5000570ecae3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Imported Google Group message.
Sender:Martin Buhr.
Date:Saturday, 17 October 2015 17:19:13 UTC+1.

Did you create an organisation and a user?

  • Yes I did…

Is the dashboard process showing any errors or output when you try the login or just what you sent with your first message?

  • Nope… Please see the attached screen shot

Can you send a screenshot of the error in the browser?

  • Attached

Are you accessing the VM via a proxy or firewall or something else that could be influencing the request?

  • Mostly not… If it is then I should not even able to open the login page.

  • show quoted text -

Imported Google Group message.
Sender:Kasinath Nalla.
Date:Saturday, 17 October 2015 17:24:21 UTC+1.

Hi Kasinath,

Ok cool - can you send me your tyk_analytics.conf file?

Cheers,
Martin

Imported Google Group message.
Sender:Martin Buhr.
Date:Saturday, 17 October 2015 17:42:21 UTC+1.

Attached both tyk and tyk_analytics.conf file

  • show quoted text -

Imported Google Group message.
Sender:Kasinath Nalla.
Date:Saturday, 17 October 2015 17:48:03 UTC+1.

Hi Kasinath,

I think I know what it is. Your Tyk Dashboard instance can’t see your Redis DB, you will need to check the connectivity and settings of the box running the dashboard.

Make sure the correct settings are in the tyk_analytics.conf file. The dashboard doesn’t error out when it can’t initially connect.

Sometimes, “localhost” does not resolve correctly, so instead use 127.0.0.1.

The behaviour you are seeing is happening because Tyk Dashboard logs you in (it verifies your u/p with Mongo), and then tries to create a session in Redis (this session is used to sign API requests from the web client), this fails, which means that the auth fails even though it didn’t (because the session check is missing).

You might want to make this change (localhost -> 127.0.0.1) in all configuration files that use Redis.

Cheers,
Martin

Imported Google Group message.
Sender:Martin Buhr.
Date:Saturday, 17 October 2015 17:54:16 UTC+1.

THanks Martin. I will try that…

  • show quoted text -

Imported Google Group message.
Sender:Kasinath Nalla.
Date:Sunday, 18 October 2015 18:59:47 UTC+1.

Hi Martin,
Finally I get passed the login screen…
All I did is, installed the 1.8 version… but I changed the password for redis from test to “” in tyk_analytics.conf and that worked… I am not sure thats the right thing or not

Here is the logs from tyk_analytics
WARN[0021] Problem trying to get value:redigo: nil returned
ERRO[0021] Key not found
[805 μs] 200 ‘/’
[232 μs] 200 ‘/styles/a2c01b34.sb-admin.css’
[58 ms] 200 ‘/styles/937876ba.bootstrap.min.css’
[115 μs] 200 ‘/images/a1034f45.esher.png’
[217 μs] 200 ‘/images/9bfaa800.tyk.png’
[115 ms] 301 ‘/login’
[705 μs] 200 ‘/’
[78 ms] 200 ‘/styles/05e44cbf.main.css’
[98 μs] 304 ‘/images/9bfaa800.tyk.png’
[781 ms] 200 ‘/js/app.js’
[226 μs] 200 ‘/views/api_usage.html’
[105 μs] 200 ‘/fragments/no_data.html’
[256 μs] 200 ‘/fragments/rangePicker.html’
[69 μs] 200 ‘/fragments/no_errors.html’
[2 ms] 200 ‘/api/activity/endpoints/18/9/2015/19/10/2015’
[2 ms] 200 ‘/api/errors/category/18/9/2015/19/10/2015’
[2 ms] 200 ‘/api/usage/18/9/2015/19/10/2015’
[663 μs] 200 ‘/api/versions’
[349 μs] 200 ‘/views/api_management.html’
[110 μs] 200 ‘/fragments/status_area.html’
[1240 μs] 200 ‘/api/apis’

Let me know,

  • show quoted text -

Imported Google Group message.
Sender:Kasinath Nalla.
Date:Sunday, 18 October 2015 19:04:52 UTC+1.

Hi Kasinath,

Good to hear :slight_smile:

The 1.8 version of what?

In a secure environment you should set a password for your Redis DB though.

The Redis password in Tyk.conf should be the same as tyk_analytics.conf.

Cheers,
Martin

Imported Google Group message.
Sender:Martin Buhr.
Date:Sunday, 18 October 2015 19:06:57 UTC+1.

Its not the same… I think that is the issue… Just 1.8 …But Now I know what the issue is… So I can get 1.8.3 will be working…

Thanks for all your help…I really appreciate your help all the time when I am down… Thanks again

  • show quoted text -

Imported Google Group message.
Sender:Kasinath Nalla.
Date:Sunday, 18 October 2015 19:12:38 UTC+1.

Ah I see - yes it looks like the one had a password and the other didn’t, that was the issue and I didn’t see it (d’oh!).

Should work fine once you fix the conf…

No worries - we’re here to help out! :slight_smile:

Cheers,
Martin

Imported Google Group message.
Sender:Martin Buhr.
Date:Sunday, 18 October 2015 19:17:42 UTC+1.

Martin,

Need final help (mostly :slight_smile: ) … The server installation, I will be demoing to my director to influence tyk from my side ( since I liked it)… Mean while, I wanted to see how this working with oauth and spring or java… Do you guys have any tutorials or documentation or sample project or demos?

thanks again for your help…

  • show quoted text -

Imported Google Group message.
Sender:Kasinath Nalla.
Date:Sunday, 18 October 2015 19:21:47 UTC+1.

Hi Kasinath,

I’m afraid not - the OAuth flows are quite complicated (as you would expect) - the simplest thing I would suggest is to use the password OAuth flow - it’s much simpler than standard OAuth.

If you look at the change log there’s some instructions.

Cheers,
Martin

Imported Google Group message.
Sender:Martin Buhr.
Date:Sunday, 18 October 2015 19:26:00 UTC+1.

Sure will do… Thanks.

  • show quoted text -