Lower qps when tyk gateway locd api definition from dashboard

Hi, i got 12000 QPS when load api definition via dashboard,but i got 50000+ qps when i load api definition from apps configure,the difference is so big,i don’t know why, thanks

Do you have enable_analytics set to true in both cases? Can you share both configs here?

“listen_port”: 9999,
“node_secret”: “352d20ee67be67f6340b4c0605b044b7”,
“secret”: “352d20ee67be67f6340b4c0605b044b7”,
“template_path”: “/home/lkong/workspace/mygo/src/github.com/TykTechnologies/tyk/templates”,
“use_db_app_configs”: true,
“db_app_conf_options”: {
“connection_string”: “http://9.xx.138.xx:3000”,
“node_is_segmented”: false,
“tags”: []
“disable_dashboard_zeroconf”: false,
“app_path”: “/home/lkong/workspace/mygo/src/github.com/TykTechnologies/tyk/apps”,
“middleware_path”: “/home/lkong/workspace/mygo/src/github.com/TykTechnologies/tyk/middleware”,
“storage”: {
“type”: “redis”,
“host”: “8.xx.xx.xx”,
“port”: 30000,
“username”: “”,
“password”: “sotestdev”,
“database”: 0,
“optimisation_max_idle”: 2000,
“optimisation_max_active”: 4000
“enable_analytics”: true,
“analytics_config”: {
“type”: “”,
“ignored_ips”: [],
“enable_detailed_recording”: true,
“enable_geo_ip”: false,
“geo_ip_db_path”: “”,
“normalise_urls”: {
“enabled”: true,
“normalise_uuids”: true,
“normalise_numbers”: true,
“custom_patterns”: []
“health_check”: {
“enable_health_checks”: false,
“health_check_value_timeouts”: 60
“optimisations_use_async_session_write”: true,
“allow_master_keys”: false,
“policies”: {
“policy_source”: “file”,
“policy_record_name”: “/home/lkong/workspace/mygo/src/github.com/TykTechnologies/tyk/policies/policies.json”
“hash_keys”: true,
“suppress_redis_signal_reload”: false,
“use_redis_log”: true,
“close_connections”: true,
“enable_non_transactional_rate_limiter”: true,
“enable_sentinel_rate_limiter”: false,
“experimental_process_org_off_thread”: false,
“local_session_cache”: {
“disable_cached_session_state”: false
“http_server_options”: {
“enable_websockets”: true
“uptime_tests”: {
“disable”: false,
“config”: {
“enable_uptime_analytics”: true,
“failure_trigger_sample_size”: 2,
“time_wait”: 10,
“checker_pool_size”: 50
“hostname”: “”,
“enable_custom_domains”: true,
“enable_jsvm”: true,
“oauth_redirect_uri_separator”: “;”,
“coprocess_options”: {
“enable_coprocess”: false,
“coprocess_grpc_server”: “”
“pid_file_location”: “./tyk-gateway.pid”,
“allow_insecure_configs”: true,
“public_key_path”: “”,
“close_idle_connections”: false,
“allow_remote_config”: false,
“enable_bundle_downloader”: true,
“bundle_base_url”: “”,
“global_session_lifetime”: 100,
“force_global_session_lifetime”: false,
“max_idle_connections_per_host”: 100

here is the configire, the only diffierent is “use_db_app_configs” set to true or false

@lexkong could you provide more details - how did you test QPS? which tooling and OS?

hi den, i do some debug and found the low qps is caused by other reason (too many middler)。thanks for your help,。

no worries, you are welcome