Localhost:8080/tyk/keys/create: unsupported protocol scheme

Hello,

i see i got an error and no one posted it yet.
It’s my first tyk on premise installation, i’m following the tuto from
https:// tyk.io/blog/docs/tyk-api-gateway-v1-9/tutorials/set-up-your-first-api/

when creating my first API key, i got this error. :
level=error msg=“Failed to create key: Post localhost:8080/tyk/keys/create: unsupported protocol scheme “localhost””

Somewhere in the configuration, i must have forgot the “https://”

If someone already knows where to look, that could help me.
I’ll post the answer once (if) i found the solution

Thanks

found it !
in tyk_analytics.conf

i changed

“tyk_api_config”: {
“Host”: “localhost”,
“Port”: “8080”,
“Secret”: “XXXXX”
},

to

“tyk_api_config”: {
“Host”: “https://localhost”,
“Port”: “8080”,
“Secret”: “XXXXX”
},

maybe it was a mistake from me on the installation,
carefull replace https by http if you didn’t enable the https

then
service tyk-dashboard restart

1 Like

Glad you got it sorted, you solved it very quickly :wink: