Hello Martin,

I want to deloy TYK on my real server. I have a problem with NGINX

Currently, My server is setting up NGINX listening port 80 that it’s running in docker container.

Your TYK GATEWAY config is binding port 80 .

Ref Link :

How can I link NGINX with TYK GATEWAY via port 80?

Tks for your support

Change this line:

so it’s:

- "9090:8080"

That will unmap port 80 in the container (well, map it to 9090, but since you’re not using it, that’s ok.

Hello Martin

I’ve already run the TYK GATEWAY container but when I access My API or Portal I see an error :

503 Service Temporarily Unavailable


I guest that it could not be forward from NGINX.

Have you any suggestion for this issue?

Tks for your support

I’m not sure what you’ve done? Have you disabled the port and restarted the compose set?

Are you accessing the container directly or via NGinX?

Sr…, it’s my mistake, I forgot to add IP & port 3000, 8080 in router rules of my firewall.

Now, everything is ok.

Tks for your support

1 Like