Kubernetes Ingress and Dev Portal

We followed the Tyk Kubernetes docs (mostly) and everything seems to work fine except for the Developer Portal. We have the Tyk Dashboard container running as ‘tyk-dashboard’ service.

We have an org, a user, an api, a policy, and it is published to the portal. We set the portal CNAME, and have an ingress rule to forward it. We can log into the Dashboard, see our users, can add more, etc.

DNS is all set, and our Ingress rules simplified are:

api-dashboard.domain.com -> tyk-dashboard:3000 path: /
portal-api-dashboard.domain.com -> tyk-dashboard:3000 path: /portal/

We have tried monkeying around with the portal ingress, and everything we try is getting a 404 “not found” but not from the Ingress controller (I recognize our default backend 404).

I don’t see anything in our logs that would indicate any issues.

Any tips on how we can troubleshoot and fix this?

We found out that we can reach the portal by using the org id in the URL. But I don’t see that being necessary in the docs anywhere, and that is not the URL the dashboard makes for the tab at the top.

Still don’t have a fix for this - Dev portal is not usable as the generated links do not work, only a manually entered URL with the OrgId does.

Facing the same issue. Whatever I try, I’m getting a 404. I added an ingress with a dedicated domain for the developer and configured the same domain in the dashboard (Your developer portal -> Set your portal domain). I also tried hardcoding it in the tyk_analytics.conf. No dice.

Can someone please offer some insight? The docs keep recommending to add the portal domain to etc/hosts. I even tried that, but still no luck.

Using the ORG ID in the dashboard URL (like bmcgough suggests) does work, but clicking on any other link will break it, because it uses a different root URL.

Hi Pavle,

Could you please share yours tyk_analytics.conf here? Also please check do you have enabled “enable_host_names”: true

“host_config” : {
“enable_host_names”: true

That’s it! Thanks a lot!

Please consider adding this to the documentation. By default, this value is set to false:

On top of that, current documentation for tyk_analytics states the following:

host_config.enable_host_names: Tyk Dashboard can bind the Dashboard application to a specific domain name, enable this option to have Tyk Dashboard only allow access on a specific domain and 404 on any other host access (not recommended).

It’s pretty vague and also ends with “not recommended”.