How to use docker install tyk-hybrid

we want to use Tyk to manage our API, and we use it with Tyk hybrid.
up to now , I follow the document :
when i run the command:(I mean the step2 for linux)
I got a image for docker , but when i run the image, there is something wrong,the logs like follow:
→ NginX Disabled
→ Starting Tyk Hybrid

Starting redis-server: redis-server.
time=“Jul 30 03:23:25” level=error msg=“Couldn’t unmarshal configuration”
time=“Jul 30 03:23:25” level=error msg=“invalid character ‘,’ looking for beginning of value”
time=“Jul 30 03:23:25” level=fatal msg=“Redis connection details not set, please ensure that the storage type is set to Redis and that the connection parameters are correct.”

I am thinking maybe i should do something ,to config my Nginx \redis and Tyk , but i don’t know how to do it???

by the way, i am successful by follow this guide: Docker. but we just want to try tyk-hybrid !!!

please help me,thank you

With the hybrid tutorial, you will see that you need a hybrid-enabled cloud account - we can provide you with a trial if yu like, it is not possible to self-sign up to hybrid.

What is happening here is that you are not using the script which bootstraps the container for you with the correct settings.

It’s not necessary to use the file, but certain EMC variables must be set.

Let me know if you’d like us to set you up with a trial acct.

thanks you ,but i have already got a account. i finished the guide: with tyk hybrid(create an account, i can login to my dashboard)
please tell me how to use the script, or there are any document for me???

Hi, the account must be a hybrid account - we can’t see that you have upgraded to Hybrid, since this is a paid option, we would need to enable a trial for you.

The start script usage is Step 2 of the guide here:

Let us know if you’d like us to set up a trial for you and I can put you in touch with he accounts team.


Okay, please enable a trial for me. it’s so kind for you

Great, I’ve escalated it to our accounts team and someone will be in touch :slight_smile: