Gateway Request failed with error http://dashboard.tyk.local:3000


i’m new to tik
I’m suppose to test several API management tool

i configured the on premise install on ubuntu server following this tuto
i just installed mongodb using another tuto, it didn’t worked for me

i configured all the component, add the https

i want to create my first API using this tuto
https:// Tyk API Gateway Documentation

However i see can’t call any url on the API (default port 3000)
and i got this error in the gateway log, and nobody posted this error message on the web.

here is the error message :

"level=error msg=“Request failed with error Get http://dashboard.tyk.local:3000/register/node: dial tcp: lookup dashboard.tyk.local: no such host; retrying in 5s”

repeating every 5 seconds

of course i already put my 1 year free licence

What’s specific about my infrastructure :
everything’s hosted in aws
to go out in the internet, i need to use a proxy (maybe that’s some online licence verification that does not work)

Any help would be appreciated, i can post more information if needed (didn’t want to confuse anyone)

Thanks for reading me


found it, i no longer have the error message

hope it helps someone with the same error message (maybe i did something wrong in the installation)

in the configuration file tyk_analytics.conf
i had :
“hostname”: “dashboard.tyk.local”,
“override_hostname”: “”,

i just changed the value of the hostname by my real hostname, restart the service and i no longer have the error in the logs