Fresh install - looking for a hint


#1

Imported Google Group message. Original thread at: https://groups.google.com/forum/#!topic/tyk-community-support/GLh9gLLHsio Import Date: 2016-01-19 21:02:51 +0000.
Sender:Thorsten Zenker.
Date:Wednesday, 19 November 2014 16:53:23 UTC.

tyk looks very good and want to see it in action.

Did a fresh install on Centos 7 with the tar packages from


of tyk and analytics.

analytics was startet up via
tyk-analytics --neworg --newuser
The analytics dashboard login and password screen show up
in the browser and the login is not working - this is why I am asking for a hint.

During the logins the tyk analytics logging shows:
" …Tyk.io Analytics Dashboard v0.7

Copyright Jively Ltd. 2014


Listening on port: 3000
Tyk API at: http://172.16.159.1:5000
ERRO[0014] Error trying to get value:
ERRO[0014] ERR Client sent AUTH, but no password is set
ERRO[0014] Key not found
[2 ms] 200 ‘/’
[447 μs] 200 ‘/styles/1f2549a3.sb-admin.css’
[123 ms] 200 ‘/styles/4aaae68d.bootstrap.min.css’
ERRO[0023] Could not EXPIRE key
ERRO[0023] ERR Client sent AUTH, but no password is set
ERRO[0023] Error trying to set value:
ERRO[0023] ERR Client sent AUTH, but no password is set
[138 ms] 301 ‘/login’
ERRO[0023] Error trying to get value:
ERRO[0023] ERR Client sent AUTH, but no password is set
ERRO[0023] Key not found
[3 ms] 200 ‘/’
[345 μs] 200 ‘/styles/1f2549a3.sb-admin.css’ … "

and tyk.io shows (many of them …):
/srv/tyk/bin/tyk
Tyk.io Gateway API v1.0

Copyright Jively Ltd. 2014


INFO[0000] No configuration file defined, will try to use default (./tyk.conf)
INFO[0000] Setting up analytics DB connection
INFO[0000] Using MongoDB cache purge
INFO[0000] Connecting to redis on: localhost:6379
Listening on port: 8888
INFO[0000] Listening on [::]:8888
INFO[0000] Using App Configuration from Mongo DB
INFO[0000] Loading API configurations.
INFO[0010] Not connected to analytics store, connecting…
ERRO[0010] Error trying to get all keys:
ERRO[0010] ERR Client sent AUTH, but no password is set
ERRO[0020] Error trying to get all keys:
ERRO[0020] ERR Client sent AUTH, but no password is set
ERRO[0030] Error trying to get all keys:
ERRO[0030] ERR Client sent AUTH, but no password is set
ERRO[0040] Error trying to get all keys:
ERRO[0040] ERR Client sent AUTH, but no password is set
ERRO[0050] Error trying to get all keys:
ERRO[0050] ERR Client sent AUTH, but no password is set
ERRO[0060] Error trying to get all keys:
ERRO[0060] ERR Client sent AUTH, but no password is set … "

Hint is welcome!

  • Thorsten

p.s.
tyk.conf:
{“listen_port”:8888,“secret”:“352d20ee67be67f6340b4c0605b044b7”,“template_path”:"./templates",“use_db_app_configs”:true,“app_path”:"./apps/",“storage”:{“type”:“redis”,“host”:“localhost”,“port”:6379,“username”:“user”,“password”:“password”,“database”:0},“enable_analytics”:true,“analytics_config”: {
“type”: “mongo”,
“csv_dir”: “/tmp”,
“mongo_url”: “mongodb://localhost/tyk_analytics”,
“mongo_db_name”: “tyk_analytics”,
“mongo_collection”: “tyk_analytics”,
“purge_delay”: 10
}}

cat tyk_analytics.conf
{
“listen_port”: 3000,
“tyk_api_config”: {
“Host”: “http://172.16.159.1”,
“Port”: “5000”,
“Secret”: “352d20ee67be67f6340b4c0605b044b7”
},
“mongo_url”: “mongodb://localhost/tyk_analytics”,
“page_size”: 10,
“admin_secret”: “12345”,
“redis_port”: 6379,
“redis_host”: “localhost”,
“redis_password”: “test”,
“force_api_defaults”: true,
“notify_on_change”: true,
“license_owner”: “Your Name”
}


#2

Imported Google Group message.
Sender:Thorsten Zenker.
Date:Friday, 21 November 2014 08:36:31 UTC.

Excellent: this solved it.

Thank you!

  • Thorsten

#3

Imported Google Group message.
Sender:Martin Buhr.
Date:Thursday, 20 November 2014 19:18:20 UTC.

Hi Thorsten,

Apologies I didn’t see this earlier, it looks like your configuration is sending a password to Redis and Redis isn’t configured with one, would recommend setting a password in your redis.conf file (http://redis.io/topics/security) as Tyk Dashboard requires one.

You’ll need to update the redis_password in the tyk_analytics and the tyk.conf file.

Let me know how it goes!

Martin


#4

Imported Google Group message.
Sender:Martin Buhr.
Date:Friday, 21 November 2014 08:36:31 UTC.

Excellent: this solved it.

Thank you!

  • Thorsten