Error "There was a problem proxying the request"

Imported Google Group message. Original thread at: https://groups.google.com/forum/#!topic/tyk-community-support/d6tPYfv7Bf0 Import Date: 2016-01-19 21:39:02 +0000.
Sender:Leandro Totino Pereira.
Date:Tuesday, 29 December 2015 15:05:10 UTC.

Hi guys,

I´m getting error fromthe proxy like “There was a problem proxying the request” errors. When I run curl from the server to the backend api it´s works. Anyone goes through that?

Imported Google Group message.
Sender:Martin Buhr.
Date:Tuesday, 29 December 2015 15:11:06 UTC.

Hi Leandro,

If you check the Tyk logs you’ll see why this is happening, Tyk is having problems talking to the proxied service, if there was a problem it will be output to the log file, it could be a malformed target URL.

Cheers,
Martin

On Tue, Dec 29, 2015 at 7:05 AM -0800, “Leandro Totino Pereira” [email protected] wrote:

Hi guys,

I´m getting error fromthe proxy like “There was a problem proxying the request” errors. When I run curl from the server to the backend api it´s works. Anyone goes through that?


You received this message because you are subscribed to the Google Groups “Tyk Community Support” group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To view this discussion on the web, visit https://groups.google.com/d/msgid/tyk-community-support/1d70cdbe-3548-4499-97ad-2934873f6098%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Imported Google Group message.
Sender:Leandro Totino Pereira.
Date:Tuesday, 29 December 2015 19:45:19 UTC.

Hi Martins,

Thanks for your answer, I see the error in tyk-gateway.std.err

When I execute curl command ( whithout -k and --cacert flag) it´s works fine but when I execute tyk url I get the follow error:

time=“2015-12-29T09:38:32-05:00” level=error msg=“http: proxy error: x509: certificate signed by unknown authority”

It´s works after I restarted the gateway process. Soo the problem was that the tyk-gateway need to restart to load new Linux CA certificate.

Thanks Martins

  • show quoted text -