Dial tcp getsockopt: connection refused with Identity Management setup


We are trying to setup Identity Management with LDAP and are getting those errors in the logs:

ERROR TIB: Request failed: Get http://localhost:3010/api/profiles: dial tcp getsockopt: connection refused
ERROR TIB: Request failed: Post http://localhost:3010/api/profiles/YTBhYWE5YjAtNWE5Zi00NGVlLTcxZmQtNTY2MDlhMzVkOTZl: dial tcp getsockopt: connection refused

Dashboard gateway and Pump are on the same server, mongo and redis on different ones
We are using the last version of all the tyk components.

Any would be more appreciate!!

Thanks you

Ah, you need to be running the Tyk Identity Broker - it is a separate service.

We don’t have an installable package for TIB (yet), but the tarball is here:

Installation instructions are here:

And there are further docs on our site.

We’ll be getting a proper installer up and running very soon.


Thanks Martin Sorry for the post

No worries, let me know when you’re all set up - TIB is a little tricky so happy to help you out getting it all up and running. :slight_smile:

Will do. Thank you :slight_smile:

Do you plan to write some TIB documentation and samples?

We have docs:

TIB Docs: Tyk Identity Broker

Examples: https://tyk.io/docs/tyk-identity-broker/social-examples/

Though are being fleshed out, it’s all a little lean at the moment.

Hi folks,

I experience this problem using Docker (Linux containers) on Windows 10. Could any one of you show me how to that as there is no document related?

I do have Identity-Broker running on Docker as well but I still get the same error

Thanks in advance