Dashboard shows no data


#1

Hi! I followed the instructions setting up the gateway, dashboard, and pump and also got a couple of apis working but dashboard shows no activity.

I can only see log-like information in the log browser.

I’m running all things in the same debian box. Here’s the versions running:

mongodb-org 3.0.14
redis-server 2:3.0.6-1
tyk-dashboard 1.3.1.1
tyk-gateway 2.3.1.2
tyk-pump 0.4.1.1

Any clues will be appreciated! Thanks in advance!


#2

Hello!

also got a couple of apis working

So, does it mean that you successfully proxied your API through Tyk, and gateway working as expected? So the only thing that does not work is statistics?

If so, pls ensure that tyk.conf have enable_analytics: true. It would be great if you can show your whole tyk and tyk.pump configs.

Also note, that component which responsible for statistic collection is Tyk Pump; basically it moves data from Redis to Mongo, for further aggregation. You need to ensure that Tyk Pump logs have no errors, and it sees both Redis and Mongo.

It also may help if you run Tyk Gateway instance in debug mode, by adding --debug flag. It may give some insights.

Thank you!


#3

Hi! Thanks a lot for your response!

Yes, Apis are working through Tyk and gateway working as expected.

I just found a way to see analytics playing with the date filters and there seems to be a problem with this filters as it only shows statistics if I make a wide search:

Example:

  • If I use 1/6/2016 as Start date and 31/1/2017 as end date, it shows me activity in the first 3 weeks of January 2017

  • But if I narrow that just by month, say setting start date as 1/7/2016, it shows me no activity at all.

Thanks again!
Rodolfo

Here’s tyk.conf

{
  "listen_port": 8080,
  "node_secret": "352d20ee67be67f6340b4c0605b044b7",
  "secret": "352d20ee67be67f6340b4c0605b044b7",
  "template_path": "/opt/tyk-gateway/templates",
  "tyk_js_path": "/opt/tyk-gateway/js/tyk.js",
  "use_db_app_configs": true,
  "db_app_conf_options": {
        "connection_string": "",
        "node_is_segmented": false,
        "tags": []
  },
  "disable_dashboard_zeroconf": false,
  "app_path": "/opt/tyk-gateway/apps",
  "middleware_path": "/opt/tyk-gateway/middleware",
  "storage": {
    "type": "redis",
    "host": "localhost",
    "port": 6379,
    "username": "",
    "password": "",
    "database": 0,
    "optimisation_max_idle": 2000,
    "optimisation_max_active": 4000
  },
  "enable_analytics": true,
  "analytics_config": {
    "type": "mongo",
    "pool_size": 100,
    "csv_dir": "/tmp",
    "mongo_url": "",
    "mongo_db_name": "",
    "mongo_collection": "",
    "purge_delay": 100,
    "ignored_ips": [],
    "enable_detailed_recording": true,
    "enable_geo_ip": false,
    "geo_ip_db_path": "",
    "normalise_urls": {
          "enabled": true,
          "normalise_uuids": true,
          "normalise_numbers": true,
          "custom_patterns": []
      }
  },
  "health_check": {
    "enable_health_checks": false,
    "health_check_value_timeouts": 60
  },
  "optimisations_use_async_session_write": true,
  "allow_master_keys": false,
  "policies": {
    "policy_source": "service",
    "policy_connection_string": "",
    "policy_record_name": "tyk_policies",
    "allow_explicit_policy_id": true
  },
  "hash_keys": true,
  "suppress_redis_signal_reload": false,
  "use_redis_log": true,
  "close_connections": true,
  "enable_non_transactional_rate_limiter": true,
  "enable_sentinel_rate_limiter": false,
  "experimental_process_org_off_thread": true,
  "local_session_cache": {
    "disable_cached_session_state": false
  },
  "http_server_options": {
        "enable_websockets": true
  },
  "uptime_tests": {
    "disable": false,
    "config": {
      "enable_uptime_analytics": true,
      "failure_trigger_sample_size": 3,
      "time_wait": 300,
      "checker_pool_size": 50
    }
  },
  "hostname": "",
  "enable_custom_domains": true,
  "enable_jsvm": true,
  "oauth_redirect_uri_separator": ";",
  "coprocess_options": {
    "enable_coprocess": false,
    "coprocess_grpc_server": ""
  },
  "pid_file_location": "./tyk-gateway.pid",
  "allow_insecure_configs": true,
  "public_key_path": "",
  "close_idle_connections": false,
  "allow_remote_config": false,
  "enable_bundle_downloader": true,
  "bundle_base_url": "",
  "global_session_lifetime": 100,
  "force_global_session_lifetime": false,
  "max_idle_connections_per_host": 100
}

Here’s pump.conf

{
    "analytics_storage_type": "redis",
    "analytics_storage_config": {
        "type": "redis",
        "host": "localhost",
        "port": 6379,
        "hosts": null,
        "username": "",
        "password": "",
        "database": 0,
        "optimisation_max_idle": 100,
        "optimisation_max_active": 0,
        "enable_cluster": false
    },
    "purge_delay": 10,
    "pumps": {
        "mongo": {
            "name": "mongo",
            "meta": {
                "collection_name": "tyk_analytics",
                "mongo_url": "mongodb://127.0.0.1/tyk_analytics"
            }
        },
        "mongo-pump-aggregate": {
            "name": "mongo-pump-aggregate",
            "meta": {
                "mongo_url": "mongodb://127.0.0.1/tyk_analytics",
                "use_mixed_collection": true
            }
        }
    },
    "uptime_pump_config": {
        "collection_name": "tyk_uptime_analytics",
        "mongo_url": "mongodb://127.0.0.1/tyk_analytics"
    },
    "dont_purge_uptime_data": false
}

#4

Heres an example if I narrow the search:


#5

Thank you!

I see, this is indeed strange issue.

I added this to our backlog and will report here any details, once we figure our what happening.

Leonid, Tyk team