Dashboard not showing usage statistics


#1

Imported Google Group message. Original thread at: https://groups.google.com/forum/#!topic/tyk-community-support/wQu4ZKFLCkg Import Date: 2016-01-19 21:17:19 +0000.
Sender:Marcelo.
Date:Thursday, 2 July 2015 05:51:02 UTC+1.

Hello everyone,

My Tyk dashboard stopped showing usage statistics. Tyk, Tyk-analytics, Nginx and Mongo are running properly as well as all my APIs. I’m using Tyk v1.6 and Tyk Analytics v0.9.4.4. Has anyone with the same problem? Thanks in advance!


#2

Imported Google Group message.
Sender:Martin Buhr.
Date:Thursday, 2 July 2015 12:15:08 UTC+1.

Hi Marcelo,

Dug a little deeper into this, it turns out that very large data sets cause problems for Mongo’s aggregation framework, when it tries to handle large sort operations in RAM, and the size of the sorted object is too big, it will fail unless you explicitly allow the DB to flush to disk, which it will not do by default (and can’t be set as a default option either).

We’ve issued an update for the dashboard (version 0.9.5.1) which solves it for the current version, I’ve also put up a new 0.9.4.5 patch release on our github releases page, it’s been smoke tested so should work just fine with your installation.

Let me know if it works.

Cheers,
Martin


#3

Imported Google Group message.
Sender:Marcelo.
Date:Thursday, 2 July 2015 06:23:59 UTC+1.

Did it used to show statistics? As in, is this an existing installation that has stopped showing stats? What version of MongoDB are you running? Tyk needs 2.5+

If it’s an existing install, are there records in the tyk_analytics collection? That’s where they get purged to.

There’s an odd case sometimes where stats stop showing if there’s a massive amount of records in the collection for a single aggregation unit (day, hour etc). E.g after doing a load test. Upgrading Mongo to 3.0 can fix this though.


#4

Imported Google Group message.
Sender:Martin Buhr.
Date:Thursday, 2 July 2015 13:04:09 UTC+1.

Yes, this is an existing install and everything always worked fine. There are about 500k records in tyk_analytics collection.

You got exactly right, if I filter a large amount of data Tyk dashboard and Tyk Activity by key not show anything. I tested with 5 days filter and chart worked ok.

I’ll apply 0.9.4.5 patch and post the results soon.

Thank you Martin.

  • show quoted text -