Dashboard bootstrap process fails on CentOS


#1

Using the follwoing guide to setup the dashboard on CentOS: https://tyk.io/docs/get-started/with-tyk-on-premise/installation/redhat-rhel-centos/dashboard/

selinux and firewalld are both disabled

When I try and bootstrap the dashboard I get the following error…

/opt/tyk-dashboard/install/bootstrap.sh apigateway
Found Python interpreter at: /bin/python
 
Creating Organisation
ERROR: Unable to connect to the Dashboard. Please check that you are using the correct hostname.

I tried using the FQDN, the hostname, the IP, and localhost.
Bootstrap will not work.

Also tried various settings for setup.sh, just keeps failing.

Another thing I noticed is that

/var/opt/tyk-dashboard/tyk_analytics.conf

this file does not live in that folder.
In fact it lives in…

/opt/tyk-dashboard


#2

You can vim the script and check what it’s doing.
The script makes an api call to the dashboard, so dashboard has to be up and running. Is the dashboard running? It needs its config file to run.


#3

It wasn’t loading.

I have to change both redis and mongodb hosts to the loopback address (127.0.0.1)

Thanks


#4

The dashboards needs mongo to run :slight_smile: