Couldn't dispatch request, driver 'python' isn't available

Hi there,

I’m trying to setup a response plugin following the instructions from Response Plugins, but when the gateway tries to process a new request, I get the following error

{"@timestamp":“2021-06-30T13:43:49Z”,"@version":“1”,“error”:“Couldn’t dispatch request, driver ‘python’ isn’t available”,“level”:“debug”,“message”:“Couldn’t dispatch request object”,“type”:“tyk-gateway”}

I have added the following lines to my api config
“custom_middleware”: {
“response”: [
{
“name”: “ResponseHook”,
“path”: “middleware/middleware.py”
}
],
“driver”: “python”
},

And the following lines to my tyk.config file

“coprocess_options”: {
“enable_coprocess”: true,
“python_path_prefix”: “/opt/tyk-gateway”
},

Base system is the oss docker installation.

Any idea?

Hi Juan,

There’s an issue with loading your plugin from the file system at the moment. Please use a bundle as per Plugin Bundles and it will work for you.

Cheers,
Pete

Hi Pete,

Thanks for your feedback. Indeed, using the bundle, the python driver is working properly.

Is this issue expected to be solved?

Regards

Hi Juan,

Yes, we’re working on a fix for it. I don’t have a release schedule I’m afraid.

Cheers,
Pete

1 Like

Hi Pete,

Any update when will the issue with loading plugin from the file system be resolved?

I have tried the same with gateway v3.2.1.

Hi @Yeshwanth.ONE ,

I’m afraid this is still in the backlog. I don’t have a date for it at this time.

Cheers,
Pete

Cool. i’m implementing goplugin.
Thanks for the update. @Pete

golang plugins load fine from the filesystem or from a bundle.

1 Like