Can not access My Developer Portal


#1

Hi,

I have an error during setup my developer portal,

When I go to http://tyk-portal.zzz.com/portal/ by browser, status code return is 200 OK but nothing at here. I got a message in gateway’s log:

TYK-GATEWAY :

http: proxy error: dial tcp [::1]:3000: getsockopt: connection refused

It’s ok when i go to http://tyk-portal.zzz.com:3000/5718b27fba68c60001000005/portal/ in Target URL from API Designer - Edit API

plz, someone help me.

Thank you!


#2

Are you using the docker installation?


#3

Hi Martin,

Yes , here is my list of containers

LIST OF CONTAINER :

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES

a9fa166d1eff mongo:latest “/entrypoint.sh mongo” 37 minutes ago Up 37 minutes 0.0.0.0:27017->27017/tcp tykquickstart_tyk_mongo_1

16046c14c84f redis:latest “/entrypoint.sh redis” 37 minutes ago Up 37 minutes 0.0.0.0:6379->6379/tcp tykquickstart_tyk_redis_1

387f43ee4c19 tykio/tyk-pump-docker-pub:latest “/opt/tyk-pump/tyk-pu” 38 minutes ago Up 37 minutes tykquickstart_tyk_pump_1

c65a029b6fe4 tykio/tyk-dashboard:latest “/opt/tyk-dashboard/t” 38 minutes ago Up 34 minutes 0.0.0.0:3000->3000/tcp, 0.0.0.0:5000->5000/tcp tykquickstart_tyk_dashboard_1

2e1da69855bb tykio/tyk-gateway:latest “/opt/tyk-gateway/tyk” 38 minutes ago Up 32 minutes 0.0.0.0:8080->8080/tcp, 0.0.0.0:80->8080/tcp tykquickstart_tyk_gateway_1


#4

Ok, in your dashboard, there will be a bunch of APIs listed but greyed out, these represent the forward proxy for your portal and will be accessible via port 80.

I am assuming you’ve managed to get an API to work, so all you need to do is fix the internal routing for the portal entries.

In the docker quickster, the portal is routed via the gateway, so the domain that is set as the target_url in each of the policy API Definitions needs to be the resolvable network name inside the Docker container / compose network.


#5

Yes, it’s worked with any register API .

About the portal

I have to access the container tykquickstart_tyk_dashboard_1 to do that?

Could you guide me step by step to fix ?

My local IP / Docker IP : 192.168.1.248


#6

Not really - docker has this annoying problem of renaming things internally on different architectures, you can try changing the hosts in those entries to be tykquickstart_tyk_dashboard_1, although the aliases defined in the compose file should also work (tyk_dashboard).


#7

I tried to convert from docker-compose.yml to command line for tyk_gateway container.

Everything is ok and I don’t know why . :joy:

Anyway tks for your support.

Truong.H