Caching appears to not occur

I’ve got caching working in my Docker install, and see the response headers
X-Tyk-Cache-Action-Set →1
X-Tyk-Cache-Action-Set-Ttl →300
to know its there. We’ve set up Tyk on a server. I’ve enabled cache on the API Definition, but don’t get the headers in the response. Are there other config options outside the API Definition that are needed to enable it?

Not really, those headers are for upstream control, so you need to enable caching (enable caching box ticked) and then also “Enable upstream cache control”.

You say you have it working in the docker box, but not on your server install?