Basic installation of oss versions -just the tyk gateway and not the operator

Just done a basic install (OSS version) of the Gateway and not the operator
installed redis and set password in value.yml and the pod and svc come up in k8s
SSL not installed

helm repo add tyk-helm
helm repo update
kubectl create namespace tyk

helm show values tyk-helm/tyk-headless > values.yaml
helm install tyk-redis bitnami/redis -n tyk
(I also did a clean install with helm install redis tyk-helm/simple-redis -n tyk as well and still doesn’t work)

Update the redis password
helm install tyk-ce tyk-helm/tyk-headless --version 0.9.1 -f values.yaml -n tyk

I used helm chart for both redis and the gateway as per the video
when I do a curl:localhost:8080/hello as per thee docs I get

{“status”:“fail”,“version”:“v3.2.1”,“description”:“Tyk GW”,“details”:{“redis”:{“status”:“fail”,“output”:“storage: Redis is either down or ws not configured”,“componentType”:“datastore”,“time”:“2021-08-07T19:28:08Z”}}}

Redis is up and I can connect to it.

There was no reference to configuring storage in redis


If I used GitHub - TykTechnologies/tyk-oss-k8s-deployment: Deployment yamls to run Tyk Gateway and Redis in a Kubernetes environment. this works.

So clearly an issue with the helm chart examples

Hey @simoncmore - welcome to the forum. Appreciate you spotting and reporting this, we’ll take a look and get back to you!

Don’t bother, I looked through the source code and worked if out my self !

Glad you were able to fix the issue. Could you share with the community how you went about resolving it?