AWS setup of Tyk Gateway and Dashboard done..but not working

I have installed Tyk Gateway and Dashboard latest community edition on AWS Red Hat Linux single node.
My dashboard URL is not working (404) although process is up. http://domain-name:3000/.
The process is starting, but i see following errors repeating every second in tyk-gateway.stderr.
I also went through other posts and entered the host name and binded to 127.0.0.1 and ensured I did the bootstrap.sh using
sudo /opt/tyk-dashboard/install/bootstrap.sh domainname. This was also successful…

DONE

Login at http://<:3000/
User: <>@default.com
Pass: <>

time=“Jul 26 09:45:52” level=info msg=“Setting up analytics normaliser”
time=“Jul 26 09:45:52” level=info msg=“Setting up Server”
time=“Jul 26 09:45:52” level=info msg="–> Standard listener (http)"
time=“Jul 26 09:45:52” level=info msg=“Registering node.”
time=“Jul 26 09:45:52” level=error msg=“Request failed: Get 1/register/node: unsupported protocol scheme “””

1 Like

Hi, can you share your tyk.conf?

{
“listen_port”: 8080,
“node_secret”: “352d20ee67be67f6340b4c0605b044b7”,
“secret”: “352d20ee67be67f6340b4c0605b044b7”,
“template_path”: “/opt/tyk-gateway/templates”,
“tyk_js_path”: “/opt/tyk-gateway/js/tyk.js”,
“use_db_app_configs”: true,
“db_app_conf_options”: {
“connection_string”: “1”,
“node_is_segmented”: false,
“tags”: []
},
“app_path”: “/opt/tyk-gateway/apps”,
“middleware_path”: “/opt/tyk-gateway/middleware”,
“storage”: {
“type”: “redis”,
“host”: “localhost”,
“port”: 6379,
“username”: “”,
“password”: “”,
“database”: 0,
“optimisation_max_idle”: 2000,
“optimisation_max_active”: 4000
},
“enable_analytics”: true,
“analytics_config”: {
“type”: “mongo”,
“csv_dir”: “/tmp”,
“mongo_url”: “”,
“mongo_db_name”: “”,
“mongo_collection”: “”,
“purge_delay”: 100,
“ignored_ips”: [],
“enable_detailed_recording”: true,
“enable_geo_ip”: false,
“geo_ip_db_path”: “”,
“normalise_urls”: {
“enabled”: true,
“normalise_uuids”: true,
“normalise_numbers”: true,
“custom_patterns”: []
}
},
“health_check”: {
“enable_health_checks”: false,
“health_check_value_timeouts”: 60
},
“optimisations_use_async_session_write”: true,
“allow_master_keys”: false,
“policies”: {
“policy_source”: “service”,
“policy_connection_string”: “1”,
“policy_record_name”: “tyk_policies”
},
“hash_keys”: true,
“suppress_redis_signal_reload”: false,
“close_connections”: true,
“enable_non_transactional_rate_limiter”: true,
“enable_sentinel_rate_limiter”: false,
“local_session_cache”: {
“disable_cached_session_state”: false
},
“http_server_options”: {
“enable_websockets”: true
},
“uptime_tests”: {
“disable”: false,
“config”: {
“enable_uptime_analytics”: true,
“failure_trigger_sample_size”: 3,
“time_wait”: 300,
“checker_pool_size”: 50
}
},
“hostname”: “”,
“enable_custom_domains”: true,
“enable_jsvm”: true
}

Your connection string is just “1”, it should be the full path to your gateway hostname

My aws instance got terminated being a POC and I could not recover back. Apologies for not connecting back earlier.
I restarted my Tyk install using Docker, the install steps are completely done now. Please see
Adding new user
USER AUTH: ####
USER ID: ###
Setting password
Setting up the portal domain
Setting up the Portal catalogue
Setting target URL for Portal APIs
Creating the Portal Home page

DONE

Login at http://###:3000/
Username: ###@test.com
Password: ###
Portal: http://www.tyk-portal-test.com/portal/

When I login now, it says credentials are invalid. Not sure how to trouble shoot this

I solved the issue it was a problem with /etc/hosts. I am able to login to dashboard

1 Like