Regex in ListenPath doesnt work with strip Prefix

If you use a Gorilla Mux path in the listen_path, then the Strip of Prefix wont work anymore I think it’s related to you guys using strings.Replace for the strip.
Perhaps here:

Any workaround? Say you want to achieve case insensitiviness, in your routes… You’d need a mux {(i?) path…}. What are our options…
We’re trying all we can in our company to not modify Tyk’s core code. But this is becoming an imposibility.

Don’t strip the listen path.

Yes, if you read above we already knew that…

Do you guys have a workaround? This is important, and I assume a feature pretty much useful for an Api Gateway.

You’d be surprised how many features are useful for a gateway, we don;t have this feature I’m afraid.

You could set up two different APIs instead of trying to bundle it all into one configuration