Portal not working following tyk-pro-docker-demo

Hi,

I am following this:

TykTechnologies/tyk-pro-docker-demo (using Dashboard: v1.7.1, and Gateway: v2.7.1)

Had to resolve these, for the dashboard to work:

  1. The dashboard was crashing, as I had to change the tyk_analytics value: host_config > enable_host_names to false to make the components run

  2. I had to add these property missing in the repo above: “identity_broker” > “enabled” as false

  3. Then the issue around how to get the user name to login to dashboard (fixed this by creating user calling the dashboard API “api/users”)

Issue pending:
Now the issue is that I cannot access the portal
I am using this url to access the portal {dashboard-url}:3000/portal
Where, dashboard-url is set in tyk_analytics.conf under host_config > hostname

I have also tried these options:

  1. Creating an initial portal page, just to be sure if that is not the issue.
  2. Explicitly giving the portal domain under host_config > portal_domains

Can someone please help me to make the portal work?

Thanks,

Update:
I have also tried doing these steps:
Using both the dashboard UI and Calling the Admin API

  1. Updated the cname to “”; cname_enabled is already set to true. Tried to access portal - not working
  2. Set the portal domain updating the cname value with the new domain, – still not working
  3. Do a refresh, still portal not accessible using the cname set. I used {c-name}:3000/portal to access portal

The portal domain along with the dashboard is set to 127.0.0.1 in etc/hosts file.

Tyk_analytics.conf

{
“listen_port”: 3000,
“tyk_api_config”: {
“Host”: “http://tyk-gateway”,
“Port”: “8080”,
“Secret”: “352d20ee67be67f6340b4c0605b044b7”
},
“mongo_url”: “mongodb://tyk-mongo:27017/tyk_analytics”,
“page_size”: 10,
“admin_secret”: “12345”,
“shared_node_secret”: “352d20ee67be67f6340b4c0605b044b7”,
“redis_port”: 6379,
“redis_host”: “tyk-redis”,
“redis_password”: “”,
“enable_cluster”: false,
“force_api_defaults”: false,
“notify_on_change”: true,
“license_key”: “removed_here_only”,
“redis_database”: 0,
“redis_hosts”: null,
“hash_keys”: true,
“email_backend”: {
“enable_email_notifications”: false,
“code”: “sendgrid”,
“settings”: {
“ClientKey”: “”
},
“default_from_email”: "[email protected]",
“default_from_name”: “Some Person”
},
“hide_listen_path”: false,
“sentry_code”: “”,
“sentry_js_code”: “”,
“use_sentry”: false,
“enable_master_keys”: false,
“enable_duplicate_slugs”: true,
“show_org_id”: true,
“host_config”: {
“enable_host_names”: false,
“disable_org_slug_prefix”: true,
“hostname”: “www.tyk-test.com”,
“override_hostname”: “”,
“portal_domains”: {},
“portal_root_path”: “/portal”,
“generate_secure_paths”: false,
“use_strict_hostmatch”: false
},
“http_server_options”: {
“use_ssl”: false,
“certificates”: [],
“min_version”: 0
},
“identity_broker”: {
“enabled”: false,
“host”: {
“connection_string”: “”,
“secret”: “”
}
},
“ui”: {
“languages”: {
“Chinese”: “cn”,
“English”: “en”,
“Korean”: “ko”
},
“hide_help”: true,
“default_lang”: “en”,
“login_page”: {},
“nav”: {
“dont_show_admin_sockets”: false,
“hide_activity_by_api_section”: false,
“hide_geo”: false,
“hide_licenses_section”: false,
“hide_logs”: false,
“hide_tib_section”: false
},
“uptime”: {},
“portal_section”: null,
“designer”: {},
“dont_show_admin_sockets”: false,
“dont_allow_license_management”: false,
“dont_allow_license_management_view”: false
},
“home_dir”: “/opt/tyk-dashboard”,
“tagging_options”: {
“tag_all_apis_by_org”: false
},
“use_sharded_analytics”: true,
“enable_aggregate_lookups”: true,
“enable_analytics_cache”: false,
“aggregate_lookup_cutoff”: “01/07/2016”,
“maintenance_mode”: false,
“allow_explicit_policy_id”: true,
“private_key_path”: “”,
“node_schema_path”: “”,
“oauth_redirect_uri_separator”: “;”,
“statsd_connection_string”: “”,
“statsd_prefix”: “”
}

You need enable host names to true and thing that will get you there

thanks @Josh, that was it.

It is working now :slight_smile: