Multiple authentication using Authtoken and Custom Auth plugin not working after upgrading tyk gateway from 2.9.2 to 2.9.4

Hi ,
I am upgrading my tyk-gateway from 2.92 to 2.94 as I want to use Json Schema Validation which was reported as bug tyk-2913 and was corrected in 2.9.4 version.

When I updated tyk-gateway to version 2.9.4 i have encounter a major problem my multiple authentication which was working correctly earlier (tyk-gateway version 2.9.2) is not working now.

Since I have deployed a loadbalancer in front of tyk-gateway. I have one of my instance with tyk-gateway v2.92 and one with v2.94.Every second request is getting failed and i am fetting bellow error

Any help will be appreciated.

Thanks
Tushar