Getting 404 errors in a high percentage of requests


I was trying to evaluate the latency that Tyk Cloud introduces, so I created a dumb api and tried to do some requests and do the same directly againts the api. However I was surprised to find out that aproximately 25-30% of the requests done through tyk failed with a 404 error (none failed directly with the api). I checked with a web browser just refreshing instead of a test program and found out the same, a high percentage of the requests failed when going through tyk but they never failed when going directly to the api.

What could be wrong?

An example of the url that fails just refreshing it enough times:

Many thanks.

Hi @Fernando_Herrero,

Thanks for letting us know - it looks like there’s been an issue in our gateway layer that hasn’t shown up on our tests - we’re investigating now. It should be resolved soon.

Many thanks,


This issue should be resolved by now.

Many thanks,

Thank you very much Martin, I can confirm that the issue has been solved.

Best Regards,


Hi @Martin,

I had same issue
including header - version: 1.0.0

My workaround: the issue was only disappeared when I open “EDIT API” page and then click “update” button.

Please help show me how to resolve the issue.

Toan Do

It can take a few minutes for an API to fully propagate across all instances - we’ll investigate why this took so long for you.