Developer's Portal endpoint not using API custom domain in Tyk 2.0


#1

I have set up nginx as a reverse proxy to take requests from the following two domains:
dev.example.com => tyk-dashboard requests
api.example.com => tyk-gateway requests

In the API designer I set the custom domain to be “api.example.com”. But when I login to the API documentation page in developer’s portal, the “endpoint” input box eventually shows “dev.example.com”, even though initially it was showing “http://api.example.com”. Thus all the requests through the doc page would not work since it was sending to the incorrect domain.

This issue seems to only be appearing at Tyk 2.0 + dashboard 1.0 but now Tyk 1.9 + dashboard 0.9. Any ideas?


#2

If you are using NGinX to handle domain routing, you will want to disable all custom domain handling in Tyk and dashboard and not set a Portal domain, instead use the org ID rewrite that is used in the host manager templates.

Alternatively you will need to forward the host header to the dashboard and ensure the port information is part of that (domain binding is very strict)