Dashboard's Activity by API broken after 1.8.3 upgrade

After upgrading to Dashboard 1.8.3 this morning, I no longer see any data in the “Activity by API” view. I do still see new requests in the Log Browser. Not sure what changed / what I’m missing. Here’s what my Activity by API view shows now:

Here’s my pump.conf:

    "analytics_storage_type": "redis",
    "analytics_storage_config": {
        "type": "redis",
        "host": "localhost",
        "port": 6379,
        "hosts": null,
        "username": "",
        "password": "",
        "database": 0,
        "optimisation_max_idle": 100,
        "optimisation_max_active": 500,
        "enable_cluster": false
    "purge_delay": 10,
    "pumps": {
        "mongo": {
            "name": "mongo",
            "meta": {
                "collection_name": "tyk_analytics",
                "mongo_url": "mongodb://",
                "collection_cap_max_size_bytes": 1048576,
                "collection_cap_enable": true
        "mongo-pump-aggregate": {
            "name": "mongo-pump-aggregate",
            "meta": {
                "mongo_url": "mongodb://",
                "use_mixed_collection": true
    "uptime_pump_config": {
        "collection_name": "tyk_uptime_analytics",
        "mongo_url": "mongodb://",
        "collection_cap_max_size_bytes": 1048576,
        "collection_cap_enable": true
    "dont_purge_uptime_data": false

Seeing anything obvious that would explain this? Thanks!

Hi! Can you also give dashboard config?

Thank you!

Of course, sorry about that. Here’s tyk_analytics.conf:

    "listen_port": 3000,
    "tyk_api_config": {
        "Host": "https://localhost",
        "Port": "443",
        "Secret": "SECRET OMITTED"
    "mongo_url": "mongodb://",
    "mongo_use_ssl": false,
    "mongo_ssl_insecure_skip_verify": false,
    "mongo_session_consistency": "",
    "page_size": 10,
    "shared_node_secret": "SECRET_OMITTED",
    "redis_port": 6379,
    "redis_host": "localhost",
    "redis_password": "",
    "enable_cluster": false,
    "redis_use_ssl": false,
    "redis_ssl_insecure_skip_verify": false,
    "force_api_defaults": false,
    "notify_on_change": true,
    "license_key": "KEY OMITTED",
    "redis_database": 0,
    "redis_hosts": null,
    "hash_keys": false,
    "email_backend": {
        "enable_email_notifications": false,
        "code": "",
        "settings": null,
        "default_from_email": "",
        "default_from_name": "",
        "dashboard_hostname": ""
    "hide_listen_path": false,
    "sentry_code": "",
    "sentry_js_code": "",
    "use_sentry": false,
    "enable_master_keys": false,
    "enable_duplicate_slugs": true,
    "show_org_id": true,
    "host_config": {
        "enable_host_names": true,
        "disable_org_slug_prefix": true,
        "hostname": "HOSTNAME OMITTED",
        "override_hostname": "",
        "portal_domains": {},
        "portal_root_path": "/portal",
        "generate_secure_paths": false,
        "secure_cookies": false,
        "use_strict_hostmatch": false
    "http_server_options": {
        "use_ssl": true,
        "certificates": [
        "min_version": 771,
        "ssl_ciphers": null,
        "ssl_insecure_skip_verify": false,
        "prefer_server_ciphers": false
    "security": {
        "allow_admin_reset_password": false,
        "login_failure_username_limit": 0,
        "login_failure_ip_limit": 0,
        "login_failure_expiration": 0,
        "login_disallow_forward_proxy": false,
        "audit_log_path": ""
    "ui": {
        "languages": {
            "Chinese": "cn",
            "English": "en",
            "Korean": "ko"
        "hide_help": false,
        "default_lang": "en",
        "login_page": {},
        "nav": {},
        "uptime": {},
        "portal_section": null,
        "designer": {},
        "dont_show_admin_sockets": false,
        "dont_allow_license_management": false,
        "dont_allow_license_management_view": false,
        "cloud": false
    "home_dir": "/opt/tyk-dashboard",
    "identity_broker": {
        "enabled": false,
        "host": {
            "connection_string": "http://localhost:3010",
            "secret": "SECRET OMITTED"
    "tagging_options": {
        "tag_all_apis_by_org": false
    "use_sharded_analytics": false,
    "enable_aggregate_lookups": true,
    "enable_analytics_cache": false,
    "aggregate_lookup_cutoff": "01/07/2016",
    "maintenance_mode": false,
    "allow_explicit_policy_id": false,
    "private_key_path": "",
    "node_schema_path": "",
    "oauth_redirect_uri_separator": ";",
    "statsd_connection_string": "",
    "statsd_prefix": "",
    "disable_parallel_sessions": false,
    "dashboard_session_lifetime": 0,
    "alternative_dashboard_url": "",
    "sso_permission_defaults": null,
    "sso_default_group_id": "",
    "sso_custom_login_url": "",
    "sso_custom_portal_login_url": "",
    "notifications_listen_port": 5000,
    "portal_session_lifetime": 0,
    "enable_delete_key_by_hash": false

Are there limits or delays before data will show up in the Activity by API/Key views and the graphs throughout the Dashboard? To further debug this, I just tried downgrading to 1.8.0 (the version I upgraded from) and there was still no data in those views. I then downgraded to 1.6.3 to match what we have in production, and there was still no data in those views on this test box. The test box is something we really only use when testing upgrades or demo APIs, and it receives very little API traffic (before today, there was nothing for months). I’m wondering if there some minimum data or time needed to populate the aggregate indexes that drive the graphs and views? Seems like a long shot, but would explain why I’m seeing transactions in the log browser but not in the views.

Another data point - I dropped just the tyk-gateway 1.8.3 package onto our production server as a test (leaving gateway and pump untouched) and the Activity by API/Key views do have rows of data displayed, unlike the same version on our test server. The Gateway Dashboard’s “Average Usage over Time” is still completely zero’ed out, though. On our prod server it should show thousands of daily requests across all of our APIs.

We are investigating issue. Temporary fix for you is to set:
“use_sharded_analytics”: true,


Are there any errors in browser console?
Can you share logs of the Dashboard service?
You can get logs using command

journalctl -f -u tyk-dashboard

What’s the version of pump and gateway?