Can't make tyk-gateway connect to tyk-dashboard

Hi all,

When I run tyk-gateway with dashboard=1 option I’m getting the following error:

[May 23 17:41:03] INFO main: Setting up analytics normaliser
[May 23 17:41:03] INFO main: PIDFile location set to: ./
[May 23 17:41:03] INFO main: Initialising Tyk REST API Endpoints
[May 23 17:41:03] WARN File descriptor limit 1024 too low for production use. Min 80000 recommended.
This could have a significant negative impact on performance.
Please refer to // for further guidance.
[May 23 17:41:03] INFO Redis connection pools are ready after number of retires currRetry=0
[May 23 17:41:03] INFO main: Redis connection pools are ready
[May 23 17:41:03] INFO main: → Standard listener (http) port=:8080
[May 23 17:41:03] INFO main: Setting up Server
[May 23 17:41:03] INFO main: Waiting for zeroconf signal…
[May 23 17:41:05] WARN pub-sub: Insecure configuration detected (allowing)!
[May 23 17:41:05] INFO pub-sub: Hostname set with dashboard zeroconf signal
[May 23 17:41:05] INFO main: Registering node.
[May 23 17:41:10] ERROR Request failed with error Get http://XXX.XXX.XXX.XXX:3000/register/node: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers); retrying in 5s

I setup tyk-gateway to start with the following settings:

sudo /opt/tyk-gateway/install/ --dashboard=1 --listenport=8080 --redishost=localhost --redisport=6379

Did anyone have the same problem?

Script by default assume that your dash running on http://localhost:3000 in general just generate config for you, ensure that generate tyk.conf points to valid address of already running dashboard.

Hope it helps.

1 Like

Hi Leon,

I actually found that the problem was in tyk-analytics.conf. The hostname parameter was set to http://XXX.XXX.XXX.XXX. It seems that the script didn’t change this by itself. So I set this to my correct hostname and now it’s working.

Thanks for your help.

Best regards,

1 Like