Cannot have service discovery in conjunction with target url

I have backend API with the target URL:{endpoints}, with various endpoints defined in endpoints designer. However, when I switch to service discovery the requests becomes http://xx.xx.xx.xx:pppp/{endponints}" and I can’t find a way to add the “/API/foo” part into the request. Is there a way out of this?

Yep, you can do this with the Target Path option in the service discovery component, this value will be appended to the server:port construct that Tyk extracts form the SD service:

Is this in dashboard 1.0 only? I could not find it in v0.9

This is only in Dashboard 1.0

Can service discovery DNS be generated with https scheme? It appears to be http only for now.

HTTPS should work - it’s just a net/http handler, you need to make sure the cert is valid and not self signed though.