Cannot access Tyk portal via proxy URL

I am unable to access the TYK portal via the proxy url Accessing it via that is giving me the error
{ error: "There was a problem proxying the request" }

I am currently using a docker based on-premises setup with settings as in the tyk-quickstart repository
thanks in advace

Hi Pulkit,

The portal won’t work unless it has been correctly configured - are you able to confirm that you’ve set this up with at least one published API (details on how to do this can be found here)?

If setting that up still doesn’t work, it might be worth adding a trailing forward slash to the end of the URL when making a GET request to it (i.e., Let me know if that works or if you’re still having trouble with your portal.

Kind regards,
Jess @ Tyk

Hey Jess, Thanks for your reply. I can confirm that i have correctly setup the portal following the same tutorial. Moreover i can access the portal by directly hitting the target URL with my browser. The error is thrown only when i try to use the API proxy url.

And i just tried. Putting the extra slash does not help

Hi Pulkit,

Have you checked your SSL settings? One Docker user who reported the issue in the past turned out to have SSL issues which could explain your case. We do have a Troubleshooting guide that mentions a proxying issue that can cause this but it wasn’t really targeted at Docker users (you may want to update your Docker image just in case however).

I’m unable to replicate the problem unfortunately, so if fixing the SSL configuration or updating the Docker image doesn’t work, could you please try attaching your API definitions to this ticket (you can export APIs to JSON format using the yellow button on the “Edit API” page)?

Kind regards,
Jess @ Tyk

If you are using the docker quickstart, can you confirm which one you are using? It was recently replaced with a newer version which doesn;t rely on the gateway proxying your portal:

Is there a way to check if there is an SSL issue ?. Where are the logs stored when using the docker version

I think i am using an older version, the one that was used in this link here. Ill try using the updated version and see if that works.

Hey Martin,
I tried the tyk-docker-pro-demo , and in this it is throwing a not found error when accessing the portal link directly and a connection refused error when accessed through the proxy url :sweat: . I have successfully set up the portal and also added the API catalogue to it. Is there anything I am missing.

Thanks in advance

Hi Pulkit,

Have you definitely added the to your hosts file? The newer Docker build that Martin linked to also mentions that you would need to add to /etc/hosts before this could work.

Kind regards,
Jess @ Tyk

yup, I followed the instructions exactly as given in the repo’s readme and added both the domains to /etc/hosts

one thing that i have noticed is that when i try to open the portal from the “your developer portal” menu on the top it takes me to a completely different non-existant IP address and the request fails with a connection timeout

You need to set the cname using the drop-down before it starts working.

Hey Martin
I have already done that , Although I did it using the API instead since the dropdown was having some issues