Can not access Developer Portal


#1

Hi Sir,

I have installed TYK on Ubuntu (On Premises) and able to access dashboard, but I could not access Developer Portal (here is the URL that I try: my-ip/portal). Could you advise how to solve this problem?

Here is my config in tyk_analytics.conf
{
“listen_port”: 3000,
“tyk_api_config”: {
“Host”: “http://localhost”,
“Port”: “8080”,
“Secret”: “352d20ee67be67f6340b4c0605b044b7”
},
“mongo_url”: “mongodb://127.0.0.1/tyk_analytics”,
“page_size”: 10,
“admin_secret”: “12345”,
“shared_node_secret”: “352d20ee67be67f6340b4c0605b044b7”,
“redis_port”: 6379,
“redis_host”: “localhost”,
“redis_password”: “”,
“enable_cluster”: false,
“force_api_defaults”: false,
“notify_on_change”: true,
“license_key”: “[my-key]”,
“redis_database”: 0,
“redis_hosts”: null,
“hash_keys”: true,
“email_backend”: {
“enable_email_notifications”: false,
“code”: “”,
“settings”: null,
“default_from_email”: “”,
“default_from_name”: “”
},
“hide_listen_path”: false,
“sentry_code”: “”,
“sentry_js_code”: “”,
“use_sentry”: false,
“enable_master_keys”: false,
“enable_duplicate_slugs”: true,
“show_org_id”: true,
“host_config”: {
“enable_host_names”: true,
“disable_org_slug_prefix”: false,
“hostname”: “[my-ip]”,
“override_hostname”: “”,
“portal_domains”: {},
“portal_root_path”: “/portal”,
“generate_secure_paths”: false
},
“http_server_options”: {
“use_ssl”: false,
“certificates”: [
{
“domain_name”: “”,
“cert_file”: “”,
“key_file”: “”
}
],
“min_version”: 0
},
“ui”: {
“languages”: {
“Chinese”: “cn”,
“English”: “en”,
“Korean”: “ko”
},
“hide_help”: false,
“default_lang”: “en”,
“login_page”: {},
“nav”: {},
“uptime”: {},
“portal_section”: null,
“designer”: {},
“dont_show_admin_sockets”: false,
“dont_allow_license_management”: false,
“dont_allow_license_management_view”: false
},
“home_dir”: “/opt/tyk-dashboard”,
“identity_broker”: {
“enabled”: false,
“host”: {
“connection_string”: “http://localhost:3010”,
“secret”: “934893845123491238192381486djfhr87234827348”
}
},
“tagging_options”: {
“tag_all_apis_by_org”: false
},
“use_sharded_analytics”: false,
“enable_aggregate_lookups”: true,
“aggregate_lookup_cutoff”: “01/07/2016”,
“maintenance_mode”: false,
“allow_explicit_policy_id”: false
}


#2

Hi Narongrit_Tuntivarac,

how do you access the portal? Which URLs are you using for the portal and the dashboard?
Do you get any HTTP error?

Thanks,
Kos @ Tyk Support Team


#3

Hi Kos,

Thank for quick response.
I access dashboard via http://[my-ip]:3000.
and use http://[my-ip]:3000/portal for the portal.
I got error 404 Not Found.

Thanks,
Narongrit


#4

Hi Narongrit_Tuntivarac,

you should access it via the domain name and not the IP.
Have you modified your

/etc/hosts

at all? Are you using a valid domain name?

Thanks,
Kos @ Tyk Support Team