Access Rights Drop Down Empty

I have recently installed Tyk Dashboard on Ubuntu 16.04. The Dashboard appears fine, but after creating an API that API does not show up in the access rights drop down for both the Create Key and Create Policy screens. I did attempt to create a key using the dashboard API and everything worked fine. I

Is there some reason why the Access Rights Drop down is empty?

1 Like

Is the api open? If it is open then it will not appear.

The API is not open. Authentication Mode is set to Auth Token. As I mentioned, I can still use the API to set it up. I just can’t use the dashboard.

How did you create the API?


I created the API through the dashboard. This worked fine, however when creating a key none of the created apis show up on the UI. For this reason I had to use the dashboard api to create the keys rather than being able to create the key from the dashboard. I have the same problem when trying to create a policy.

Another problem I have noticed although I am not sure if it related to the problem is that the API Usage data screens are do not show any activity other than the Gatewaylogs.

Attached is the screenshot of one of the APIs created via the dashboard that does not show up as Access Rights drop down on the Key and Policy screens.

Given this behavior do you have any suggestions of what log or setting I should investigate?

I should also mention that the dashboard version is



Hmmm, how did you create the user for the dashboard that is performing all these actions?

If the user is a superbuser (no org) then this behaviour might happen. But if the user belongs to the org, then it shouldn’t.

I think there was an issue with the mongodb configuration. I wiped the install and started over and everything but the analytics dashboard is working right now.


1 Like

Hey there - Im having this same issue here. Im following the docker install info (Docker and Docker). I tried to customize the dashboard login with this docker command:
docker run -d --name tyk_dashboard -p 3000:3000 --link tyk_redis:redis --link tyk_mongo:mongo --link tyk_gateway:tyk_gateway -v $(pwd)/tyk_analytics.with_mongo_and_gateway.conf:/opt/tyk-dashboard/tyk.conf tykio/tyk-dashboard

However, when I try to create a policy it looks for access rights which is always blank. How do I get something in there?